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1. WYMAGANIA SPRZĘTOWE PROGRAMU 
 

Pakiet zaprojektowany został jako 32-bitowa aplikacja do pracy w środowisku Windows XP, 

Vista, Windows7/8/10 (32 lub 64 bity) 

 

Konfiguracja minimalna 

1. Komputer z pamięcią 4 GB (zalecana >= 6 GB) RAM, wolne miejsce na dysku twardym > 5 

GB, CD-ROM. 

2. Monitor 19"(zalecany 24”) Tryb pracy - minimalna rozdzielczość 1280 x 800 zalecana 1920 x 

1200 lub 1920 x 1024 

 

 

1. Instalując sterowniki do bazy danych zaleca się wykorzystać Firebird 2.5x 

Podczas instalowania należy zwrócić uwagę na dwa elementy: 

2. Instalacja sterownika klucza HASP/SENTINEL – system, o ile nie jest to zablokowane, 

pobiera automatycznie poprzez Internet sterowniki (nie dotyczy wersji demo) 

3. Instalując sterowniki do bazy danych zaleca się wykorzystać Firebird wersja 2.5 

1.1. INSTALACJA 

Pakiet CPT-STAR może pracować samodzielnie na jednym komputerze, w wersji 

jednostanowiskowej lub wielostanowiskowej w sieci, gdzie dane przechowywane są w bazie 

danych na serwerze, a aplikacje klienckie należy zainstalować na każdym stanowisku roboczym. 

Z danych na serwerze może wtedy korzystać kilku użytkowników. Tak jak w przypadku wersji 

jednostanowiskowej, każdy mało zaawansowany pod względem informatycznym użytkownik, 

może zainstalować pakiet CPT-STAR, tak w przypadku pracy sieciowej wymagana jest bardziej 

zaawansowana wiedza informatyczna administrowania systemem.  

Instalacje oprogramowania wykonujemy z uprawnieniami administratora. W dalszej części 

opisano instalacje programu w różnych przypadkach. 

 

1.2. Instalacja jednostanowiskowa (szybka) 

Konieczne oprogramowanie składa się z dwóch części - firmowego oprogramowania GeoStar 

6i/7i oraz sterowników bazy danych. Instalacje zaczynamy od firmowego oprogramowania 

GeoStar, zawartego na dostarczonej płycie oraz jego sterowników.  

Wkładamy płytę instalacyjną GeoStar i instalujemy po kolei: 

1. Programy użytkowe z katalogu CPT-STAR 

2. Sterownik klucza Hasp z katalogu Klucz Hasp/Sentinel (dla Windows 7/8/10 sterowniki 

pobierane są automatycznie przez Internet po włożeniu klucza) 

Następnie wkładamy płytę ze sterownikami Firebird 2.5x (lub pobieramy je z Internetu)  

3. Sterowniki Baz danych Firebird 2.5.x 

 

 

UWAGI:  

1 Sterowniki klucza Hasp/Sentinel nie są potrzebne w przypadku wersji demo 

2 Zainstalowanie sterowników bazy danych Firebird jest konieczne do działania 

oprogramowania użytkowego.  
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2. INFORMACJE OGÓLNE 
Do najnowszej wersji oprogramowania CPT-STAR dodano szereg zmian i ulepszeń w stosunku 

do wersji wcześniejszej. W wersji wcześniejszej warstwy były często wydzielane na podstawie 

klasyfikacji parametrycznej na podstawie charakterystyk (np. metody. Robertsona, 

Schmertmanna). Często niewłaściwa klasyfikacja gruntów byłą przyczyną błędów.  

W aktualnej wersji programu wydzielenia warstw profilu roboczego można skorelować z 

profilem porównawczym tzn. znanym profilem warstw gruntu (uzyskanym np. w wyniku 

wiercenia) znajdującym się w niezbyt dużej odległości od profilu badanego.  

Najważniejsze zmiany to: 

 

 Wydzielanie warstw profilu na podstawie profilu porównawczego oraz równoległy jego 

podgląd wraz z profilem roboczym (badawczym) 

 Manualne - na wykresach, korygowanie wartkości średnich parametrów warstw poprzez 

ich przesuwanie myszką 

 Ulepszona i rozbudowana o dodatkowe opcje tabela warstw gruntów. 

 Poprawiono i rozbudowano definiowanie metod własnych użytkownika. 

 Uniezależniono wykonywanie algorytmów od klasyfikacji parametrycznej z 

charakterystyk 

 Ulepszono współpracę z programem GeoStar w tym dodano opcję wczytywania 

istniejącego profilu GeoStar jako profilu porównawczego. 

 Inne drobne korekty i ulepszenia 

 

 

Pakiet CPT-Star jest, opracowanym w całości w kraju, programem komputerowym do 

dokumentowania badań gruntów wykonanych sondą statyczną, oferującym wykonanie 

wykresów zmierzonych parametrów oraz pełną klasyfikację rodzajów gruntu.   Program 

posiadający grafikę skalowaną oraz w pełni graficzne środowisko pracy i umożliwia także 

integracje (zachowanie danych, wprowadzenie wyników do bazy danych, kopiowanie wykresów 

na przekroje geologiczne) z programem GeoStar 6/7i Professional/Ultimate 

Program wykonuje: 

1. Prezentację wczytanych z sondy danych pomiarowych,  

2. Wylicza szereg parametrów użytecznych do oceny stanu gruntu, 

3. Opcjonalnie wykonuje klasyfikacje rodzaju gruntów kilkoma opublikowanymi 

metodami,  

4. Opcjonalnie wczytuje klasyfikacje gruntów (litologię) z bazy danych GeoStar, 

5. Oblicza parametry w sposób ciągły oraz średnie dla wyznaczonych warstw, 

6. Eksportuje do bazy danych GeoStar wyliczone parametry warstw lub całą 

klasyfikację, 

7. Eksportuje do arkusza Excel wyliczone parametry warstw wraz z klasyfikacją. 

 

 

Program wczytuje dane z sondy pomiarowej ze stożkiem elektrycznym. Firma Soft-Projekt 

zapewnia, w miarę możliwości, dostosowanie programu do formatu danych tworzonych przez 

sondy różnych firm światowych. 

Program zapisuje dane we własnym formacie. Parametry wejściowe z sondy, jak i obliczane 

przez program, zapisywane są w oddzielnych kanałach. Parametrom, wykorzystywanym do 

dalszych obliczeń, przyporządkowano stałe kanały, przydzielone przez producenta programu. 

Program ma do swojej dyspozycji 50 kanałów, co stwarza dużą rezerwę na przyszłość. Na Rys. 1 

i 2 rozpisano kanały i przyporządkowane im parametry. 
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Rys. 1 Kanały standardowe z sondy i przeliczane programu CPT-Star – kanały 1-30 

Cha- 

nnel 
symbol Phisical Value Formula Units Notes 

1 qc Point resistance  MPa  

2 fs Sleeve friction resistance  MPa  

3 u2 

 

Pore pressure behind 

cone 

 MPa  

15 Rf Friction ratio  %  

16 u0 Dissipation test result  MPa if data not exists then zero 

17 qt Corrected point resistence qt = qc + u(1 - a) MPA  

18 ft Corrected local friction ft = fs - u * b MPA  

19 vo 
Total overburden stress  vo(h) = hi * i(h) MPA i – density 

20 vo’ Effective total overburden 

str 
vo’ = vo – u0 MPA u0 – dissipation result 

21 qt - vo qt-sigmaVo qt - vo MPA  

22 Qt Normalized cone resistance   

 

 

23 Fr Normalized friction ratio  % 

 

 

24 

 

 

 

 

 

 

 

Bq 

 

Pore pressure parameter 

 

  

 

 

25 Rf(qc) Friction ratio fs/qc*100%   

26 u0 Hydrostatic pressure  MPA  

27 Rfd Friction ratio (NEN5140)  %  

28      

29      

30  Soil bar classification No    

 

where:  a- probe area factor a 

 b- probe area factor b 

 

Q
q

t
t

vo






vo

'

F
f

qt
r

s
vo

B
u u

q
q

o

t




vo
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Rys. 2 Wszystkie kanały CPT 
Channel Parameter Symbol Unit Precision 

1 Point resistance qc MPa 3 

2 Sleeve friction resistance fs MPa 3 

3 Pore pressure behind cone u2 MPa 4 

4    3 

5    3 

6    1 

7    3 

8    3 

9    3 

10    2 

11    3 

12 Czas t s 3 

13 Prędkość ondowania v cm/s 3 

14    3 

15 Friction ratio = ft/qt*100% Rf % 3 

16 Dissipation Uo MPa 3 

17 Corrected point resistance qt MPa 3 

18 Corrected local friction ft MPa 3 

19 Total overburden stress  sigmaVo MPa 3 

20 Effective total overburden str sigma'Vo MPa 3 

21 qt-sigmaVo qt-sigmaVo MPa 3 

22 Normalized cone resistance Qt  3 

23 Normalized friction ratio Fr % 3 

24 Pore pressure parameter Bq  4 

25 Friction ratio = fs/qc*100% Rf(qc) % 3 

26 Hydrostatic pressure Uh MPa 3 

27 Friction ratio (NEN5140) Rfd % 3 

28    3 

29    3 

30 Wynik klasyfikacji grunt  0 

31 Relative Density ID Id  3 

32 Plasticity index Il IL  3 

33 Efektywny kt tarcia (Effective friction angle) Fi’ deg 3 

34 Sume Rf Sum(Rf) % 2 

35 Sume Qc Sum(Qc) MPa 2 

36 Rf (medium in range) Rf med % 3 

37 Qc (medium in range) Qc med MPa 3 

38    2 

39    2 

40    2 

41    2 

42    2 

43    2 

44    2 

45    2 

46    2 

47    2 

48    2 

49 Identyfikator metody klasyfika IDKlas  0 

50 Ground name Code / Kod szrafury Szraf.  0 

51 Nm Nm  3 

52 OCR OCR  2 

53 Koefficient of earth pressure  Ko  3 

54 Commpresion modulus / Modu odksztacenia  Mo MPa 3 

55 Napreenie prekonsolidacyjne sigma'p  3 

56 Constrained modulus / Modu odksztacenia (constrained modul M MPa 3 

57 Undrained shear strength / Niedrenowana wytrzymaołość Su MPa 3 

58 Moduł edometryczny Eoed MPa 3 

59    0 

60    0 

61    0 

62    0 

63    0 

64    0 

65    0 

66    0 

67    0 

68    0 
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69    0 

70    0 

 

Program dostosowywany jest do sondy umożliwiając wczytanie danych z kilku rodzajów sond 

ze stożkiem elektrycznym. Niezależnie wczytane i przetworzone dane można zachować we 

własnym formacie programu, gdzie oprócz danych z sondy, zachowywane są klasyfikacje 

gruntów i wyliczane parametry.  

 

Dane sondy wczytywane są z plików sondy poprzez import. Przy wyborze pliku należy oznaczyć 

odpowiednio producenta sondy. Program do obliczeń wykorzystuje jako jednostkę ciśnienia 

[MPa], natomiast sondy różnych producentów zachowują dane w różnych jednostkach. Z 

tego powodu, podczas importu danych z sondy, dane są przemnażane przez współczynniki 

do [MPa].  

3. Działanie pakietu i jego wykorzystanie 

3.1. Działanie 

Praktycznie przy pomocy pakietu CPT można wykonać całą część graficzną dokumentacji 

sondowań statycznych oraz uzyskać dane konieczne do wykonania części opisowej. 

Wykonywanie dokumentacji odbywa się etapami, wykorzystując kolejno odpowiednie moduły. 

Zadaniem modułu jest odczytanie danych pomiarowych z plików zachowanych wyników 

sondowań, klasyfikacja gruntów wg ich rodzajów. W efekcie użytkownik uzyskuje rysunek, na 

którym utrzymuje słupek z litologią badanego gruntu oraz wykresy z wybranymi parametrami 

jakościowymi, a w szczególności danych odczytanych z sondy.  Wyniki mogą być 

przedstawione: 

w sposób analityczny – bez wydzielania warstw, parametry wczytane i przetwarzane są w 

sposób ciągły w funkcji głębokości 

w sposób syntetyczny (menu Layers) -  wydzielane są warstwy, przeprowadza się klasyfikacje 

gruntów i dla tych warstw i oblicza parametry średnie. Dodatkowo obliczane jest odchylenie 

standardowe i przedział ufności obliczonych parametrów. 

 

Wejściowe dane pomiarowe, z sondy ze stożkiem elektrycznym, zapisywane są na ogół w 

postaci trzech parametrów do trzech kanałów: 

1 – Point resistance – qc, 

2 – Local friction – fs, 

3 – Pore pressure – u, 

 

Niezależnie należy wprowadzić wyniki testów dyssypacji, poziom wody gruntowej, a w 

przypadku podwiertu (predriling) jego głębokość i gęstość gruntu w obszarze podwiertu. 

W pierwszej kolejności obliczane są parametry wykorzystywane najczęściej do interpretacji 

metodami „klasycznymi”.  

 

Parametry stanu gruntu liczone są w warstwach po wybraniu odpowiedniej opcji z menu 

Layers programu. Warstwy wyznacza się: 

1. Manualnie, 

2. Na podstawie zintegrowanych w programie metod klasyfikacji, 

3. Poprzez pobranie litologii z oprogramowania GeoStar, 

 

 Oprogramowanie zawiera kilka zintegrowanych graficzno-numerycznych metod klasyfikacji 

rodzajów gruntu: 

 metoda Robertsona z 1986 roku 
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    metoda Robertsona z 1992 roku 

    metoda Schmertmanna 

    Wg Polskiej Normy – adaptacja nomogramu Mara 

 

Często stosowana jest metoda opublikowana przez Robertsona 1986. Metodę tę wraz z 

materiałami źródłowymi pokazano na rysunkach 2.1 oraz 2.2  

 

Zone Soil Behaviour 

Type 
Zone Soil Behaviour 

Type 

1 Sensitive fine 

grained 

7 Silty sand to 

silty clay 

2 Organic material 8 Sandy silt to 

clayey silt 

3 Clay 9 Sand 

4 Silty clay to clay 10 Gravely sand to 

sand 

5 Clayey silt to 

silty clay 

11 Very stiff fine 

grained   * 

6 Sandy silt to 

clayey silt 

12 Sand to clayey 

sand       * 

 

 

 

Rys. 2.1. Metoda klasyfikacji gruntów opracowana przez Robertsona w 1986 roku. 

Robertson, P.K., Campanella, R.G., Gillesie, D. And Greig, J. Use of piezometer cone data. Proceedings of the 

ASCE Specialty Conference in Situ ’86: Use of In Situ Tests in Geotechnical Engineering. ASCE. 1986. 

 

 

 

 

Zone Soil Behaviour 

Type 
Zone Soil Behaviour 

Type 

 1 Sensitive, fine 

grained 

6 Sands; clean sand 

to silty sand 

2 Organic soils-peats 7 Gravely sand to 

sand 

3 Clays; clay to silty 

clay 

8 Very stiff sand to 

clayey sand 

4 Silt mixtures; 

clayey silt to silty 

clay 

9 Very stiff fine 

grained 

5 Sand mixtures; 

silty sand to sandy 

silt 

 

 
 

 

 

 

 

Rys. 2.2. Metoda klasyfikacji gruntów opracowana przez Robertsona w 1990 roku.  

Robertson, P.K. Soil classification using the cone penetration test. Canadian Geotechnical Journal. 1990. 
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Rys. 2.03. Metoda klasyfikacji gruntów wg Polskiej normy (adaptacja nomogramu Marra).  

 

 

Wyniki klasyfikacji przedstawiane są obok wykresów wraz ze słupkiem ciągłym.  

 

 

Rys. 2.04. Metoda klasyfikacji gruntów wg Polskiej normy (adaptacja wykresu Robertsona).  
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3.2. Ustawienia i opcje  

Aby moc korzystać z pakietu w formie i zakresie odpowiadającym użytkownikowi należy 

ustawić pewne opcje i parametry 

3.2.1. Parametry ogólne programu 

 

 Parametry ogólne wybieramy 

z menu Format → Options. Na 

panelu występuje kilka zakładek.  

Można zachowywać wszystkie 

kanały co jest zalecane lub 

wybrane, gdy np. nie chcemy 

udostępniać niektórych wyników. 

 

 

Rys. 2.2. Zakładka ogólne 

 

 

 

 

 

 

 

 

 

3.2.2. Język 

 

 

 

Język tworzonej dokumentacji 

wybieramy z menu Format → 

Options → Zakładka Language. 

Wybór języka determinuje nazwy 

warstw litologicznych tworzonych 

podczas klasyfikacji jak i nazwy pól 

w tabelce opisu rysunku 

 
 

Rys. 2.3. Zakładka wyboru języka 
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3.2.3. Import 

Zakładkę import omówiono w rozdziale 3 przy okazji omawiania importu danych z sond 

różnych producentów 

 

 

 

 

3.2.4. Zakresy i kolory kanałów  

Program umożliwia ustawienie zakresu i koloru kanałów na wykresie. W tym celu wybieramy z 

menu Format → Channels Color and range. Powoduje to pojawienie się panelu; 

 

Rys. 3.6. Okienko dialogowe ustawiania zakresu i koloru kanałów na wykresie 

 

Jeśli włączymy Autoscale komputer sam dobierze zakresy wyłącznie na kanałach oznaczonych 

w kolumnie Autoscale. Kolory dobieramy klikając w kolumnie kolor na odpowiedni wiersz. 

Spowoduje to ukazanie się okna wyboru koloru. 

 

4. PRACA Z PROGRAMEM BEZ WYDZIELANIA WARSTW 

4.1. Wczytanie danych z sondy 

Dane sondy wczytywane są z plików sondy poprzez File → Import. Po zachowaniu sondowania 

sondowanie wczytuje się w formacie własnym poprzez File → Open. Importując dane z sondy 

przy wyborze pliku należy odpowiednio wybrać producenta sondy.  

Program do wykonania wszelkich obliczeń wykorzystuje jako jednostkę ciśnienia [MPa], 

natomiast sondy różnych producentów wczytywane są w różnych jednostkach. Dlatego 

podczas importu danych z sondy dane są przemnażane przez współczynniki. Współczynniki 

zadane są domyślnie przez program, ale mogą być skorygowane przez użytkownika. W tym celu 
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należy wybrać z menu Format → Options. Następnie należy wybrać zakładkę Import i 

zaznaczyć rodzaj sondy. Pokazano to na poniższym rysunku. 

 

 
 

 

 

 

Wprowadzone współczynniki są automatycznie zachowywane w pliku konfiguracyjnym. Dane z 

sondy po zaimportowaniu należy zachować w formacie własnym oprogramowania CPT. W tym 

celu wybieramy Plik → Zapisz jako (File → Save as). W celu późniejszego wczytania 

zachowanych danych wybieramy File→Open i wczytujemy sondowanie. Po wczytaniu pojawia 

się okienko z wyborem kanałów. 

Alternatywnie dane robocze mogą zostać zachowane i odczytywane z bazy danych GeoStar. Jest 

bardzo wygodne, gdyż dane grupowane są tematami opracowań, a także zapobiega to tworzeniu 

na dysku ogromnej liczby plików. Współpracę z GeoStar opisano w rozdziale 8. 

W miarę rozwoju oprogramowania ilość importowanych typów sond stale się zwiększą oraz ze 

względu na to, że niektórzy producenci czasami zmieniają format zapisu istnieje możliwość 

dostosowania procedur importu do formatu pliku danych sondy posiadanej przez użytkownika. 

 

 

Rys. 3.0 Współczynniki przemnożenia kanałów wczytywanych z sondy 
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Rys. 3.1 Okienko z wyborem kanałów w trybie pojedynczym (Single) 

 

Rys. 3.1 Okienko z wyborem kanałów w trybie wielokanałowym 
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Po wyborze kanałów pojawi się wykres zawierający wykresy wczytanych kanałów oraz 

wyliczany kanał Rf.  

 

 

Rys. 3.2. Wykres wczytanych kanałów CPT 

4.2. Klasyfikacja gruntów na podstawie charakterystyk 

 

3. Aby wykonać klasyfikację wczytanych gruntów należy wybrać z menu Clascification → 

Execute classification. Pojawi się wtedy okienko: 

 

 

Rys.3.3. Okienko wyboru metody klasyfikacji 

W następnej kolejności pojawi się okienko z ciężarami gruntów które można zmodyfikować. 
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Rys. 3.4. Okienko ciężarów gruntu dla wybranej metody klasyfikacji 

Klasyfikacja przebiega dwutorowo. Najpierw wykonywana jest metoda Robertsona z 1986 roku 

i przeprowadzana jest wstępna klasyfikacja celem wyznaczenia klasyfikacji wstępnej. Jest to 

konieczne by ustalić gęstość gruntów. Następnie przeprowadzona jest klasyfikacja właściwa w 

której używa się wprowadzonych na rysunku 3.4 ciężarów gruntu. W wyniku klasyfikacji 

uzyskujemy rysunek słupka litologicznego obok wybranych wcześniej wykresów. Czasem 

klasyfikacja wykazuje znaczną ilość bardzo cienkich kilkumilimetrowych warstw. Aby je usunąć 

należy wybrać. Narzędzia → Eliminacja cienkich warstw i wskazać grubość najcieńszej 

warstwy. Warstwy cieńsze zostaną podzielone w połowie pomiędzy warstwą górną i dolną. 
Uwaga: Wykonanie klasyfikacji gruntu tę metodą nie jest utworzeniem warstw obliczeniowych 

(Layers) a jedynie obrazkiem wyniku klasyfikacji, mogącym w dalszej części posłużyć do 

utworzenia warstw obliczeniowych, który tworzymy poprzez Layers → Create from classificatin bar 
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Rys. 3.5. Przykład interpretacji gruntów nasypowych pierwszą metodą Robertsona po wyeliminowaniu przez program cienkich 

warstw. 
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4.3. Przenoszenie wykresów na przekrój programu GeoStar 

Aby nanieść wykres sondowania CPT na przekrój wykonany programem GeoStar należy: 

 Uruchomić aplikacje przekroje pakietu GeoStar i wybrać/utworzyć przekrój, na który 

mają być naniesione wykresy sondowania CPT 

 Uruchomić program CPT i utworzyć konieczne wykresy w tej samej skali pionowej co 

przekrój GeoStar. 

 Wybrać z menu Edycja → Kopiuj specjalnie → Wykres 1...3 

 Powrócić do aplikacji przekroje i wskazujemy miejsce koło słupka litologicznego, gdzie 

ma być wklejony wykres. 

 Po wklejeniu tak ustawiamy górę wykresu by zgadzała się z głębokością zero na słupku 

przekroju.  

 Klikamy na wklejony wykres i korzystając z prawego przycisku myszy wybieramy z 

menu kontekstowego Zakotwicz. 

 Szerokość wykresu możemy zmniejszyć klikając na wykres i korzystając z prawego 

przycisku myszy wybieramy z menu kontekstowego Edytuj graficznie.   Następnie 

"chwytamy" punkt edycyjny z lewej lub prawej strony wykresu. 
 

Tak utworzony przekrój możemy zachować. W wersji Profesional i Ultimate GeoStar wczytuje 

wykres sondowania z menu Wstaw→ Sondowanie CPT 

 

4.4. Wypełnienie tabelki 

Tabelkę edytujemy wybierając z menu Format → Tabelka. Spowoduje to ukazanie się okienka 

dialogowego: 

 

 

Rys. 3.7 Okienko dialogowe edycji tabelki 
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Raz wprowadzone do tabelki dane można wykorzystać w innych testach. W tym celu po 

wprowadzeniu danych do tabelki wciskamy przycisk Kopiuj. Po wczytaniu innego testu należy 

nacisnąć przycisk Wklej. Istnieje możliwość bezpośredniego dopisywania wprowadzonych do 

tabelki danych do kolejnych importowanych sondowań poprzez wybranie It use recently 

imported tests.  

4.5. Wyprowadzanie wyników 

Rysunek sondowania może zostać wydrukowany. W tym celu należy najpierw wybrać drukarkę i 

format papieru drukarki poprzez wybór z menu Ustawienia drukarki a następnie Drukuj lub 

ikonkę drukarki na pasku zdań. 

Rysunek można zachować do pliku w formacie PDF poprzez wybór z Menu Export do PDF  

5. WYDZIELANIE WARSTW 

Wydzielenie i klasyfikacja warstw są konieczne, aby policzyć parametry gruntów. Inaczej 

liczone będą warstwy spoiste a inaczej piaszczyste. W pierwszym etapie wydzielamy przeloty 

(stropy-spągi) warstw. W drugim klasyfikujemy je przypisując określone cechy. Czasem obie te 

czynności są łączne 

Po wydzieleniu warstw pojawi się słupek litologiczny. Po jego lewej stronie paskiem żółtym 

oznaczone będą warstwy piaszczyste a różowym warstwy spoiste.  

Warstwy można wydzielić manualnie obserwując Rf lub skorzystać ze zintegrowanej 

klasyfikacji gruntów lub też zaimportować litologie wprowadzonego profilu z oprogramowania 

GeoStar. 

W celu dalszej identyfikacji wprowadzono do terminologii trzy rodzaje profili 

1. Profil roboczy 

2. Profil porównawczy 

3. Profil z klasyfikacji na podstawie charakterystyk 

Profil roboczy to profil aktualnie tworzony, którego parametry należy policzyć. Profil 

porównawczy to profil o znanej litologii znajdujący się w pobliżu profilu roboczego. Może to 

być profil wczytany z oprogramowania GeoStar. Profil roboczy tworzony jest poprzez 

porównanie jego wykresów sondowania z litologią profilu porównawczego lub profilu 

klasyfikacji parametrycznej. Profil klasyfikacji parametrycznej z charakterystyk to profil, 

którego litologia została określona wyłącznie na podstawie wyników sondowania przy pomocy 

metod Robertsona, Schmertmanna lub podobnych. Profil taki może w szczególnych 

przypadkach służyć jako pomocniczy. 

Poniżej pokazano sposób wyboru profili z menu Widok 
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Rys. 4.1 Wybór rodzaju profili z Menu 
Na rysunku obok wykresu domyślnie rysowany jest profil roboczy, jednak możliwe są także 

profile: 

- Profil roboczy obok porównawczego 

- Profil uzyskany z klasyfikacji z charakterystyk 

5.1. Metody wydzielania warstw  

Warstwy profilu mogą być wydzielane manualnie bądź automatycznie. Aby wydzielić warstwy 

manualnie wybieramy z menu Profil roboczy → Wydziel warstwy gruntów manualnie. Pojawi 

się nadążająca za myszką pozioma linia, a miejscu kliknięcia powstanie granica warstw. 

Zmiana wydzieleń istniejącego profilu roboczego możliwa jest po wybraniu z Menu Profil 

roboczy → Ręczna zmiana położenia warstw gruntów lub ikony: 

 

 
 

Po naciśnięciu ikony możliwe jest przesuwanie wskazanej myszą granicy warstw na wykresie. 

Wybranie z submenu Podziel umożliwia dodanie nowej zakończającej lub podział istniejącej 

warstwy.  Pojawia się wtedy pozioma linia podziału na głębokości wskazanej myszką.  

Wybranie Usuń usuwa wskazaną warstwę umożliwiając jej przyłączenie do górnej lub dolnej.   

Metody automatyczne wczytują warstwy sklasyfikowane na podstawie charakterystyk (np. 

Robertsona) lub wprowadzone do programu GeoStar.  

5.1.1. Metoda 1 – manualne wydzielenie warstw litologicznych na podstawie przebiegu Qc 

i Rf 

1. Włączamy wykresy Rf i Qc  

2. Wybieramy z menu Profil roboczy → Wydziel warstwy gruntów manualnie  

3. Na wykresie pojawi się przesuwająca się wraz z myszką linia pozioma. W miejscach 

znacznej zmiany Rf (przejścia jednej warstwy w drugą) klikamy lewym przyciskiem 

myszy. Po wydzieleniu wszystkich warstw klikamy przycisk Wprowadź zmiany (Apply 

changes).  
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5.1.2. Metoda 2 - wydzielenie warstw litologicznych z klasyfikacji gruntów na podstawie 

charakterystyk (np. Robertsona) 

Przed przystąpieniem do wydzielenia warstw te metoda należy przeprowadzić klasyfikacje 

gruntów (rozdział 3.2). Metoda ta przypisuje także cechy wydzielonym warstwom. 

1. Wybieramy z menu Profil roboczy → Utwórz warstwy gruntu na podstawie 

klasyfikacji (klasyfikacji parametrycznej)    

5.1.3. Metoda 3 – wydzielenie warstw litologicznych na podstawie litologii wprowadzonej 

do bazy danych GeoStar 

Litologie wprowadzoną do bazy danych GeoStar można zaimportować do aplikacji CPT-Star i 

wykorzystać do obliczeń parametrów gruntów. Odbywa się to poprzez wybór z menu Plik → 

Importuj warstwy z bazy danych GeoStar. Warstwy z GeoStar można wczytać jako Profil 

roboczy lub jako profil porównawczy. Po wyborze pojawi się okienko otworów istniejących w 

bazie danych GeoStar i należy wybrać otwór, z którego pragniemy zaimportować litologie. Jeśli 

wczytamy jako profil roboczy głębokości wyliczanych warstw będą zgodne z wprowadzonymi 

do profilu GeoStar. 

5.1.4. Metoda 4 – wydzielenie warstw litologicznych na podstawie profilu porównawczego 

W metodzie tej postępujemy podobnie jak w metodzie 1 obserwując przebiegi Qc i Rf z tym, że 

podpowiedzią jest wczytany z boku profil porównawczy.   

Poniżej pokazano wydzielanie warstw na profilu roboczym przy pomocy profilu porównaw-

czego znajdującego się na lewo od profilu roboczego. 

 
 

Rys. 4.2 Profil porownawczy i profil roboczy na jednym rysunku 
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Dane do profilu porównawczego można uzyskać z kilku źrodeł. 

1. Z danych wprowadzonego otworu do bazy danych GeoStar.  

2. Z innego profilu CPT wykonanego wcześniej 

3. Poprzez zwykłe skopiowanie profilu porównawczego wykonanego w innym programie i 

wklejenie go do programu CPT. 

 

W celu wczytania Profilu z bazy danych GeoStar wybieramy z Menu Profil porównawczy → 

Wczytaj z bazy GeoStar. Na okienku dialogowym wybieramy z listy właściwy profili i 

zaznaczamy, czy będzie to profil porównawczy. W przeciwnym wypadku zaimportowany profil 

będzie wyłącznie profilem roboczym. Można także wczytać profil porównawczy jako roboczy i 

nastanie zmodyfikować go. 

 

Aby wczytać dane do profilu porównawczego z innego wykonanego programem CPT należy 

wczytać profil znany poprzez wybór Menu Edycja → Kopiuj profil roboczy. Następnie po 

wczytaniu danych profilu roboczego wybieramy Edycja → Wklej profil jako profil 

porównawczy. 

 

 
 

Rys. Wczytanie profilu porównawczego/roboczego z bazy danych GeoStar 

 

Ważna opcją jest wybór czy profile znajdują się na tej samej rzędnej czy też na różnych. Jeśli na 

różnych to konieczne jest zaznaczenie Ustaw wg rzędnych zadanych.   W przypadku tym 

konieczne jest wprowadzenie rzędnej profilu porównawczego w bazie danych GeoStar jak i 

rzędnej gruntu w nagłówku sondowania CPT (Plik → Nagłówek 
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5.2. Manualne ustawianie cech warstw (klasyfikacja) 

Nacisnięcie warstwy na słupku Profilu roboczego spowoduje ukazanie się okienka 

umozliwiajacego wprowadzenie jej cech:  

 Litologii i symbolu gruntu ze słownika wraz z unikalnym kodem klasyfikacji. 

 rodzaju gruntu (piaszczysty, spoisty, organiczny) 

Przy wprowadzaniu litologii i symbolu gruntu korzysta się ze słowników gotowych lub 

modyfikowanych przez użytkownika. Każda pozycja ze słownika posiada unikalny Kod 

klasyfikacji. Kod ten jest wybierany automatycznie po wyborze pozycji ze słownika i umożliwia 

przyporządkowanie warstwy do metody obliczeń 

 

 
 

Rys. Po naciśnięciu warsty na słupku pojawia się okienko słownika 

 

Na wykresie widoczne są dwie linie – wartości średnich parametrów warstw (o ile zostaną 

wcześniej policzone) oraz wykres wielopunktowy pomiarów z kanału sondowania: W kazdej 

chwili klikajac warstwę można nadać i zmienić jej cechy.  

Klasyfikacja i przypisanie cech odbywa się zgodnie z wybranym bieżącym słownikiem 

klasyfikacji gruntów. 

 

 



25 

 

6. OBLICZANIE PARAMETRÓW WARSTW 

Do obliczenia parametrów warstw oprogramowanie CPT-Star stosuje wbudowane w program 

metody stałe oraz metody definiowane przez użytkownika. Metody stałe opisano w rozdziale 8. 

Sposób wprowadzania własnych metod użytkownika opisano w części 2 tej instrukcji  

Na tym etapie można przejść do obliczenia parametrów gruntu. Po wyborze z menu Warstwy → 

Tabela wyników obliczeń warstw profilu pojawi się tabelka: 

 

Rys. 5.1.1. Tabelka parametrów warstw gruntu 

W tabelce widać podział na warstwy rodzaju gruntu wraz z klasyfikacją (kolumny 2-3) oraz 

przedziały podziału na stany gruntu (kolumny 4-5). Dalsze kolumny określają obliczone 

parametry warstw stanów gruntu. 

Wybierając ikonkę Wszystkie jak i Wybrana można wybrać parametr do obliczania zarówno 

całego sondowania jak i wybranej warstwy. Program zawiera możliwość obliczeń następujących 

parametrów. 

 

Rys. 5.1.2. Parametry możliwe do policzenia 
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Kolorem pomarańczowym i czerwonym oznaczono metody które w danym momencie nie mogą 

zostać zrealizowane ze względu na brak niektórych koniecznych danych. Np. na rysunku 

powyżej wybrano obliczanie ciśnienia prekonsolidacyjnego Pp co zostało oznaczone kolorem 

czerwonym a okienku Method problems zapisano, że brak jest danych w kanele OCR co 

oznacza, że wcześniej należy obliczyć OCR. 

Jeśli liczone jest parametr dla wszystkich warstw to program wybiera automatycznie metody dla 

warstw spoistych lub piaszczystych lub organicznych. W przypadku obliczania parametrów 

wybranej warstwy może być użyta i wymuszona metoda np. dla warstw przejściowych. 

Użytkownik może także zdefiniować samodzielnie metody obliczeń. Opisano to w części 2 

dokumentacji. 

 

6.1. Manualne korygowanie wartości średnich parametrów warstw 

Po wyliczeniu, wartości średnie parametrów warstw mogą być widoczne na rysunku 

sondowania. W tym celu należy wcisnąć ikonkę ustawiania wartości średnich warstw (wskazana 

na górnym pasku zadań) 

 

 

Rys. Edycja wartości średnich parametru na profilu 

Na wykresach parametrów będą rysowane dwie linie,  

 jedna łamana z wartościami pomiarów w punktach sondowania,  

 druga wyliczonych wartości średnich 

Aby możliwa była korekcja wartości średnich parametru warstw należy 

1. Wcisnąć ikonkę ustawiania wartości średnich warstw (wskazana na górnym pasku zadań) 

2. Wybrać myszką odcinek edytowanej średniej 

3. Po ukazaniu się okienka Wartość parametru dla Warstwy – skorygować Wartość 



27 

 

7. SŁOWNIKI LITOLOGICZNE KLASYFIKACJI GRUNTÓW 
Przy klasyfikacji można używać następujacych słowników: 

 Lokalny zgodny z ISO14688-2 

 Lokalny zgodny z DIN 18196 

 Lokalny zgodny z GeoStar 

 Bezpośrednio dostępny z oprogramowania GeoStar 

 Słownik lokalny zdefiniowany indywidulanie przez użytkownika 

 

Wybór słownika odbywa się z Menu Format –> Ustawienia słowników. Oprogramowanie 

wykorzystuje słownik bieżący oraz słownik domyślny.  

Słownik bieżący to słownik, który wykorzystano wcześniej do klasyfikacji wczytanego profilu i 

dotyczy bieżącego profilu. 

Słownik domyślny to słownik, który będzie domyślnie użyty do nowo wczytywanych i 

opracowywanych sondowań.  

 

 

 

Rys.  6.1 Wybór słownika klasyfikacji gruntów 

 

 

 

Należy zwrócić uwagę by do opracowywanego profilu używać zawsze tego samego słownika. 

Jego zmiana wymaga ręcznego przeklasyfikowania wszystkich warstw.  
W przypadku, gdy wczytywane sondowanie zostało sklasyfikowane na podstawie innego słownika 

niż domyślny, słownik wczytanego profilu zostanie wczytany i ustawiony jako bieżący. Np. jeśli 

sondowanie X zostało wykonane przy pomocy klasyfikacji DIN, a jako słownik domyślny i bieżący 

ustawiony jest słownik ISO, to na czas obrabiania wyników sondowania X jako słownik bieżący 

zostanie ustawiony słownik DIN.  
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Rys.  6.2 Słownik na podstwie ISO14688-2 

 

8. WSPÓŁPRACA Z PROGRAMEM GEOSTAR 
Oprogramowanie CPT-Star jest kompatybilne w zakresie wymiany danych z oprogramowaniem 

GeoStar. Możliwe są następujące opcje 

1. Pobranie (import) z GeoStar wydzieleń litologicznych i policzenie ich parametrów 

geotechnicznych w oprogramowaniu CPT-Star 

2. Zapis wyników sondowania jak i policzonych parametrów warstw CPT do bazy danych 

GeoStar (Tabela GS_CPT). Należy zważać by o ile to możliwe słownik litologiczny GeoStar 

był zgodny ze słownikiem CPT-Star. W obu programach istnieje możliwość doboru 

słownika. 

8.1. Pobranie wydzieleń litologicznych z bazy danych GeoStar 

Z bazy danych GeoStar można pobrać wprowadzone tam wydzielenia litologiczne, użyć je jako 

warstwy (Layers) i w oprogramowaniu CPT-Star. Następnie można policzyć ich parametry. Aby 

było to możliwe w tabeli litologii GeoStar powinny być wprowadzone następujące parametry: 

 Rodzaj gruntu - RODZ. GRUNT. (P,S,O,-) 

 Kolory - KOLOR NA RYSUNKU (o ile chcemy by kolory profilu CPT były zgodne z 

oprogramowaniem GeoStar)  
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Wczytanie odbywa się po wybraniu z Menu opcji Importuj warstwy z bazy danych GeoStar 

(Import layers from Geostar database). Pojawi się okienko z wyborem otworu, którego litologia 

ma zostać zaimportowana. Po imporcie po lewej stronie rysunku CPT pojawi się słupek z 

warstwami. 

Uwaga: Kolory na rysunku w bazie danych GeoStar definiujemy naciskając z menu Litologia → Koloruj 

warstwy  

8.2. Zapis wydzielonych warstw i ich parametrów do bazy danych GeoStar 

Wyniki sondowania wraz z wydzielonymi i sklasyfikowanymi warstwami można przenieść do 

programu GeoStar 6i/7i. Obywa się to z poziomu menu głównego Plik → Eksportuj dane do 

bazy danych GeoStar (File → Export to GeoStar software) lub z poziomu Tabela wyników 

stanów gruntu (Table of soil states).  

Dane można dopisywać do bazy danych GeoStar do istniejących otworów w lub tworzyć nowe 

otwory wraz z litologią i wynikami obliczeń parametrów. 

 

 

 

  

 Nie kopiuj parametrów litologii i warstw powoduje, że w bazie GeoStar nie są 

zachowywane warstwy z wynikami obliczeń warstw 

 Utwórz nową litologię GeoStar i kopiuj z parametrami warstw powoduje, że w GeoStar 

tworzone są nowe wydzielenia litologiczne i kopiowane wraz z parametrami policzonymi 

w CPT-Star 
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 Kopiuj parametry warstw do istniejącej litologii GeoStar - opcje tę wykorzystuje się, 

jeśli wcześniej zaimportowano warstwy litologiczne z GeoStar, w oprogramowaniu CPT 

policzono ich parametry, a następnie wyliczone parametry pragniemy przekazać do 

istniejących wydzieleń w bazie danych GeoStar. 

 

Zaznaczenie Otwórz tabele bazy danych GeoStar po eksporcie (Open GeoStar database table 

after export) powoduje utworzenie uruchomienie bazy danych GeoStar i ustawienie jej pozycji 

na wprowadzonym otworze. Wprowadzanie odbywa się zawsze do aktualnie wybranego tematu 

GeoStar 

 Do bazy zostaną przeniesione informacje o położeniu sondowania, wydzielone warstwy wraz z 

litologią i obliczonymi parametrami stanu gruntu. Aby parametry stanów gruntu były widoczne 

w bazie danych należy na zakładce litologia wybrać Pokaż rozszerzone stany.   

Dane można pokazać na uniwersalnej karcie otworu. W tym celu po uruchomieniu karty należy 

wczytać szablon CPT-Full.KU1. 

8.3. Wprowadzanie wykresów i danych warstw na uniwersalnej karcie otworu 

Wyniki obliczeń CPT zachowane w bazie danych GeoStar można pokazać na uniwersalnej 

karcie otworu programu GeoStar w postaci tabelarycznej lub wykresów. O formie decyduje 

zastosowany szablon karty otworu.  

 

Rys.7.4.1 Szblon parametrów CPT na karcie otworu GeoStar (CTP-FULL.KU1) 
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Rys.7.4.1 Szblon wykresów CPT na karcie otworu GeoStar (CPT_WYKRES.KU1) 
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Rys 7.4.1 Karta otworu w programie GeoStar - dane programu CPT-Star (szablon CPT-Full.KU1) 
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Rys 7.4.2 Karta otworu w programie GeoStar z wykresem z programu CPT-Star (szablon CPT-Wykres.KU1) 
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8.4. Wprowadzanie wykresów na przekroje 

Na przekrój wykonany w programie GeoStar można nanieść wykresy sondowania CPT. Są 

możliwe dwie metody: 

1. Kopiowanie rysunku wykresu z CPT 

2. Bezpośrednie wprowadzanie w aplikacji Przekroje wybierając menu Wstaw  

Sondowanie CPT. (wersja GeoStar Profesional i Ultimate) 

Kopiowanie rysunku wykresu z CPT 

 W tym celu wykonujemy stosowny wykres w programie CPT-Star, w skali zgodnej ze skalą 

pionowej przekroju a następnie wybieramy z menu Edit → Copy Specjalny → Graph 1 to 

clipboard a następnie w otwartym przekroju wskazujemy miejsce wklejenia przekroju 

wybieramy prawym przyciskiem myszy Wklej ze schowka Windows.   

 

 

Przekrój wykonany w programie GeoStar na podstawie sondowań CPT 
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Bezpośrednie wprowadzanie wykresów w aplikacji Przekroje 

Wstawianie wykresów niektórych parametrów sondowań statycznych CPT jest możliwa w 

programie Przekroje pakietu GeoStar (wersje Professional i Ultimate). W tym celu należy 

wcześniej w programie CPT-Star zachować Dane sondowania CPT do bazy danych GeoStar 

(File  Export to GeoStar software zaznaczając co najmniej opcje Save Cpt file data to GeoStar 

CPT table)  

Następnie w oprogramowaniu Przekroje należy wybrać z menu Wstaw  Sondowanie CPT i 

określić parametr. Tę metodą na przekrój można wprowadzić wykresy tylko niektórych 

parametrów.  (Qc i RF docelowo także ID i IL) 

 

8.5. Ustawianie kodów (szrafur) dla bazy danych GeoStar – opcja dotyczy jedynie 

klasyfikacji parametrycznej na podstawie charakterystyk 

Baza danych GeoStar korzysta z innych kodów niż CPT-Star. Kody w programie CPT-Star 

dobierane są dla zadanej metody klasyfikacji gruntów zgodnie z numeracja autora. Aby w bazie 

danych GeoStar użyć kodów dla niej właściwych wykorzystywane jest ich przekodowanie.  

Dobór stosownego kodu GeoStar można przeprowadzić w programie CPT-Star. W tym celu 

wybieramy Format → Options a następnie zakładkę GeoStar. Pokazano to na poniższym 

rysunku. 

 

 

Ponieważ każda metoda interpretacji w CPT używa innego podziału na grunty – kody ustawia 

się do aktualnie użytej metody klasyfikacji (użyta metoda wyświetla się dla na dolnym pasku 

okna programu). Po zmianę kodów należy je zachować naciskając Save configuration as current.  

 

Kody programu GeoStar można przejrzeć wybierając z Menu GeoStar: Słowniki → Słownik 

litologiczny. Numery kodów znajdują się w pierwszej kolumnie słownika. 
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9. WYKAZ ZAIMPLEMENTOWANYCH METOD OBLICZEN 

PARAMETRÓW GRUNTÓW 

9.1. Stopień zagęszczenia gruntów sypkich ID (Relative density)  

Metoda 1 – zgodna z Polska normą PN-B-04452 

𝐼𝑑 = 0,79 × log 𝑞𝑐 − 0,165 
 

Metoda 2 – zgodna z Boldi 1986. (Cone Penetration Testing, T.Lune, PK. Robertson, J.J.M 

Powel, strona 84).  

𝐼𝐷 =
1

𝐶2
ln [

𝑞𝑐

𝐶0(𝜎′𝑣𝑜)𝐶1
] 

 

gdzie C0 C1 C2 zależą od przekonsolidowania gruntów 

Grunty normalnie skonsolidowane: C0=157, C1=0.55, C2=2.41 

Grunty normalne i przekonsolidowane piaski: C0=182, C1=0.55, C2=2.61 

 

 

9.2. Stopień plastyczności gruntów spoistych IL  

Metoda 1 – zgodna z Polska normą PN-B-04452 

Po wybraniu metody zgodnej z Polską normą pojawi się okienko; 

 

 

Rys. 8.2.1 Obliczanie IL warstwy metodą zgodna z Polska normą 

9.3. Efektywny kąt tarcia ' (Effective friction angle) 

 

Metoda 1 (Robertson & Campanella, 1983a) 

∅′ = 𝐭𝐚𝐧−𝟏 [𝟎, 𝟏 + 𝟎, 𝟑𝟖 × 𝐥𝐨𝐠 (
𝒒𝒕

𝝈′𝒗𝒐
)] 

Metoda 2 (Senneset 1988) 

Źródło: Cone penetrating Testing, str. 69-70 

 Obliczanie odbywa się z nomogramu wykorzystując wzór  

∅′ = 𝑓(𝐵𝑞 , 𝑁𝑚 ) 

Obliczany wstępne współczynnik Nm. zależy od rodzaju gruntu i głębokości.  
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Grunty niespoiste 

Z > 5m   Nm =  

 

Z ≤ 5m  Nm =  

 
Grunty spoiste 

Z > 5m     Nm =  

 

Z ≤ 5m    Nm =  

 

Metoda 5 - Fi based on qc (PN-B-04452) 

Metoda bazująca na qc wg: PN-B-04452 

 

Metoda 6 -  Fi based on qc (Eurokod 7) 

Zgodna z Polska normą PN-EN 1997-2 wg. Eurokod 7 

∅′ = 13,5 × log(𝑞𝑐) + 23 

9.4. OCR 

Metoda 1 (Powel 1988) 

 

𝑂𝐶𝑅 = 𝑘 ×
𝑞𝑡 − 𝜎𝑣𝑜

𝜎′𝑣𝑜
 

9.5. Współczynnik rozporu bocznego Ko 

 

Metoda 1 (Ko (Mayne 1991) 

Ko =  =  

 

9.6. Naprężenie prekonsolidacyjne ’p 

a. Dla piasków 𝜎′𝑝 = 𝑂𝐶𝑅 × 𝜎′𝑣𝑜 

b. Dla spoistych 𝜎′𝑝 = 0,33 × 𝑞𝑡 × 𝜎𝑣𝑜 
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9.7. Wrażliwość St (tylko spoiste) 

 𝑆𝑡 =
7,5

𝑅𝑓
 

9.8. Niedrenowana wytrzymałość na ścinanie Su (aktualnie oznaczana cu) 

Metoda1 (Lune 1997) 

𝑆𝑢 = 𝑘 × (𝑞𝑡 − 𝜎𝑣𝑜) 

gdzie: k zależnie od rodzaju gruntu przyjmuje różne wartości 

 

Metoda2 – zgodna z Polska normą PN-B-04452 

𝑆𝑢 =
(𝑞𝑡 − 𝜎𝑣𝑜)

𝑁𝑘𝑡
 

gdzie: k zależnie od rodzaju gruntu przyjmuje różne wartości  

 

 

Metoda3 – zgodna z Polska normą PN-EN 1997-2 wg. Eurokod 7   

𝑆𝑢 =
(𝑞𝑡 − 𝜎𝑣𝑜)

𝑁𝑘𝑡
 

9.8.1. 8.9. Moduł Edometryczny ściśliwości wtórnej Eoed 

 

Metoda 1 (Eurokod 7 wg. EN-1997-2) 

𝑀 = 𝑞𝑐 × 𝛼
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Gdzie:  zgodnie z tablicą 

 

 

9.9. Moduł ściśliwości M 

Metoda1 (Kulhavy, Mayne 1990) 

𝑀 = 𝑞𝑛 × 𝛼 × 𝛽 

Gdzie: 𝑞𝑛 = 𝑞𝑐 − 𝜎′𝑣𝑜 

 

9.10. Uwagi końcowe 

Wyniki wyliczeń można wydrukować lub przekopiować do programu Excel. 

  

if qc < 10 then  = 4.5 

 if (qc >= 10) and (qc < 20) then  = 5 

 if qc >= 20 then   = 5.5 

 

      if Rf >= 1.3 then   = 0.95; 

      if (Rf >= 0.9) and (Rf < 1.3) then  =1.05; 

      if (Rf >= 0.7) and (Rf < 0.9) then  = 1.1; 

      if (Rf >= 0.4) and (Rf < 0.7) then  = 0.15; 

      if Rf < 0.4 then  =1.2; 
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10. DODATEK I -  STOŻEK MECHANICZNY (BEGEMANA) 
 

10.1. INFORMACJE OGÓLNE 

Algorytmy interpretacji sondowań ze stożkiem mechanicznym (Begemanna) opracowano jako 

moduł dodatkowy do Pakiet CPT-Star, dodając pewne metody oraz odrzucając metody 

interpretacyjne oraz metody wyliczające parametry (stany) gruntu. Dotyczy to metod 

korzystających z ciśnienia u2. Jednocześnie program umożliwia korygowanie danych 

wczytanych ze stożka mechanicznego tak by odpowiadały parametrom ze stożka elektrycznego. 

Firma Soft-Projekt długo zwlekała z obsługą pomiarów ze stożkiem Begemanna ze względu na 

napływające informacje o jakości wyników. Jednak znaczne zainteresowanie użytkowników 

takiej sondy sprawiły ze opracowaliśmy stosowny moduł, jednak opracowane wyniki muszą 

zostać zweryfikowane przez użytkownika wykonującego interpretację.  

Aby przejść w tryb pracy sondy ze stożkiem mechanicznym należy wybrać z menu  

Format → Options, a następnie na dialogu, który się pojawi w ramce Cone options 

zaznaczyć Mechanical (Begemann). 

10.2. KOREKTA DANYCH 

10.2.1. Korekta Qc 

Dla sondy ze stożkiem elektrycznym parametr qc wczytywany jest na kanał 1 i stad brany jest do 

dalszych obliczeń. W przypadku sondy ze stożkiem mechanicznym dane qc wczytywane są 

równolegle na kanał 1 oraz 14. Po wczytaniu możliwe jest sprowadzenie wartości qc do wartości 

odpowiadających wartościom ze stożkiem elektrycznym. Odbywa się to wg zależności  

 

[1]    

19.1

47.0

ma

c

e

ea

c

p

q

p

q





















       wg. Kulchawy and Marne (1990) 

 

Aby dokonać korekty qc należy wybrać z menu Tools → qc(m) → qc(e). Po wyborze kanał 14 

pozostanie niezmieniony zachowując oryginalna wartość qc pochodzącą z sondy, natomiast 

wartości kanału 1 zostaną skorygowane wg zależności 1. 

 

10.3. OBLICZENIA 

W dalszej kolejności pracujemy podobnie jak w przypadku sondy ze stożkiem elektrycznym 

jednak w celu klasyfikacji gruntów należy używać wyłącznie metody 

1. Adaptacja nomogramu Marra 

2. Robertsona z 1986 (wyłącznie opcjonalnie) 

W przypadku wyboru sondy mechanicznej zostaną pokazane jedynie te metody obliczania 

parametrów gruntów które nie wykorzystują ciśnienia u2. 
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11. METODY ZAWANSOWANE (dostępne w wersji Professional) 
 

11.1. PORÓWNANIE WYNIKÓW UZYSKANYCH RÓŻNYMI METODAMI 

(Opcja dotyczy formuł i metod wybieranych z dialogu Layers of soil states)  

Program w wersji Professional umożliwia porównanie wyników parametru warstwy obliczonego 

różnymi metodami i wybranie wyników uznanych przez użytkownika za właściwe. Pokazano to 

na poniższym rysunku, gdzie policzono Fi różnymi metodami, a wybór właściwego wyniku 

wybieramy klikając checkbox w kolumnie Select. 

 

 

Rys. 1.1 Porównanie wyników obliczeń dla warstwy 

 

Po wybraniu Apply and Exit wyniki zostaną wprowadzone do obliczanej warstwy profilu. 

pokazano to na poniższym rysunku, gdzie wyniki zostały wprowadzone do warstwy o stropie 

0.36 m. 

 

  
 

Opcja porównania wyników działa jedynie w przypadku obliczeń pojedynczej warstwy. W 

przypadku obliczeń wszystkich warstw w profilu należy wcześniej zdecydować się na jedną 

metodę. 
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11.2. WŁASNE FORMUŁY OBLICZENIOWE 

 

Program umożliwia pisanie własnych formuł obliczeniowych dla parametru geotechnicznego 

bazujących na wartościach kanałów. Przejście do definiowania formuły odbywa się z menu 

Formulas → User formulas for layers parameters. Po wyborze opcji pojawia się okienko: 

 

Rys. 2.1. User methods for layers parameters 

Wybieramy opcje New Formula i wprowadzamy wzór formuły jako Function to Execute. 

Pokazano to poniżej. 

 

Rys. 2.2 

Dodawanie bezwarunkowej formuły użytkownika 
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Formuła może być zadana jako stała i bezwarunkowa dla całej warstwy lub wariantowa, gdzie 

wzór obliczeniowy zależy od np. Rf lub Qc. 

 

W przypadku stałego wzoru dla całej warstwy ustawiamy:  

1. Ilość wariantów formuły (Number of Farmula Variant) = 1 

2. Komórki  Pole Warunku (Condition Field) oraz Maximum Value oraz Minimum Value 

pozostawiamy puste 

3. W wierszu Funkcja do wykonania (Function to Execute) wprowadzamy wzór obliczeniowy. 

Każdy użyty we wzorze obliczeniowym kanał CPT musi być zadeklarowany w okienku Zmienne 

formuły (np. ch1). W kolumnie Przemnożenie jednostek CPT→ Formuła wstawiany wartość 1, 

chyba że wzór obliczeniowy jest w innej jednostce niż użyty kanał (np. qc w KPas) 

 

W przypadku wzoru wariantowego ustawiamy:  

1. Number of Farmula Variant = Ilość wariantów, w tym przypadku 3. Każdy wiersz określa 

jeden wariant obliczania. 

2. Condition Field - tutaj wprowadzamy zmienną warunku (kanał), od którego zależy wybór 

wzoru obliczeniowego np. Rf lu Qc 

3.Maksimum oraz Minimum Value - tutaj wprowadzamy zakres minimalny i maksymalny 

zmiennej wybranej w pkt. 2 dla kolejnego wariantu. Jeśli wartość kanału warunku znajdzie się 

pomiędzy tymi wartościami to zostanie wybrany wzór obliczeniowy tego wariantu. 

4. W wierszach Function to Execute wprowadzamy wzory obliczeniowe dla kolejnych 

wariantów 

 

 

Rys. 2.3 Dodawanie wariantowej formuły użytkownika 

Metoda pozwala obliczyć zdefiniowany parametr w sposób ciągły jako kanał wykresu CPT oraz 

jako wartości średnie dla warstw.   
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Aby zdefiniować formułę należy: 

 Podać jej unikalny identyfikator. 

 Podać pełną nazwę. 

 Zadeklarować ilość użytych zmiennych - kanałów programu CPT Zmienne formuły 

(Formula variables) 

 Zadeklarować wartości kanałów jako zmienne, np. ch1 to kanał 1 zawierający qc, a ch15 

to kanał 15 zawierający RF. Po podwójnym kliknięciu pola deklarowania zmiennej 

Declare source data channels, lista wyboru kanału pojawi się automatycznie.  

 Wprowadzić formułę obliczeniową, przy czym dopuszczalne są funkcje i znaki podane w 

górnej części dialogu oraz nawiasy. Poprawność składni formuły można sprawdzić 

naciskając przycisk Test. 

 Określić rodzaj parametru - standardowy lub użytkownika. Parametr standardowy jest 

wybierany z listy rozwijanej (np.ID) zostanie wprowadzony w stałe miejsca i kolumny 

przewidziane w programie.  W przypadku parametrów użytkownika należy wprowadzić 

symbol parametru np. ID_Autor oraz określić tzw. Indeks parametru 

 Określić Indeks parametru z zakresu 31-50 (poniżej 31 zdefiniowano parametry 

standardowe jednoznacznie przypisane do określonego parametru gruntu np. RF, ID lub 

IL). Indeks parametru wyznacza numer kolumny z wynikami obliczeń dla warstw i 

jeśli chcemy jednocześnie oglądać wyniki rożnych metod należy nadać im różne indeksy. 

 Wprowadzić maksymalną i minimalną wartość parametru. Jeśli obie wartości równe są 

zero to nie ma ograniczeń 

 Wprowadzić precyzje wyniku (ilość miejsc po przecinku) 

 Wybrać kanał CPT, na którym będzie prezentowany wykres ciągłych wartości wyniku – 

Knał wyniku (Dest graph channel). 

 Określić do jakich gruntów należy stosować procedurę (P-Piaszczyste, S-Spoiste, O- 

organiczne, PS – piaszczyste i spoiste)  

 Ignorowanie cienkich wstawek innych rodzajów gruntu przy obliczaniu parametru 

warstwy np. wstawek iłu przy liczeniu warstwy piaszczystej (zaznaczyć Ignore insertions 

of other Soils types). Opcja ta działa jedynie, jeśli wcześniej została wykonana 

klasyfikacja parametryczna na podstawie charakterystyk. 

Zdefiniowana przez użytkownika formuła pojawia się na liście metod (Formuł) parametrów 

gruntu. Należy zwrócić uwagę na pozycję Dest Channel, który musi być wybrany zgodnie z 

tabelą Tabela 2b. Wszystkie kanały CPT pokazane w głównej części instrukcji dotyczącej CPT - 

Standard. Zmienna CH17 oznacza, że wartość do wzoru należy pobrać z kanału 17. Własne formuły 

obliczeniowe można zachować do pliku formuł, a także opcjonalnie z wynikami obliczeń profilu. W 

przypadku, jeśli nie chcemy by inni ni poznali użytych wzorów i algorytmów, metodę można 

zaszyfrować. Wtedy można ją odczytać dopiero po podaniu hasła. 

Parametry wyliczone jako standardowe mają możliwość automatycznego przepisania do 

odpowiednich pól oprogramowania GeoStar. W przypadku parametrów użytkownika wyniki obliczeń 

można w razie potrzeby przepisać do oprogramowania GeoStar ręcznie lub użyć opcji kopiowania 

parametrów w tabeli Table of soil states.  

 

Wzór wariantowy dla różnych głębokości 
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Czasem występuje koniczność zadania różnych wzorów dla różnych przedziałów głębokości. 

Pokazuje to rysunek 2.4. W przedziale 0-3 m obowiązują formuły 1-3, natomiast dla > 3 m obowiązują 

formuły 4-5. 

 

Rys. 2.4 Dodawanie wariantowej, zależnej od głębokości, formuły użytkownika 

11.3. GRUPY FORMUŁ (MAKRA) 

Grupy formuł definiują cały szereg czynności, a także formuł jakie należy wykonać przy 

obliczaniu parametrów profilu. Przyspiesza to zdecydowanie obliczenia na podobnych gruntach, 

zastępując szereg powtarzających się czynności jedną procedurą. Grupa formuł jest realizowana 

po wybraniu przycisku Execute formula group. 

Procedury wywołuje się z menu Tools → Programming procedure. Pojawia się okienko, na 

którym zaznaczamy jakie czynności mają zostać wykonane  
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Rys.3.1 Definiowanie grupy formuł 

Na przykładzie pokazanym powyżej po wczytaniu pliku z danymi z sondy zostaną wykonane 

5. Redukcje pików na kanałach 1, 2 i 3 Redukcja pików na kanałach (Spikes reduction of 

Channels).  

6. Po redukcji pików zostanie wykonana klasyfikacja gruntów na podstawie charakterystyk 

np. Robertsona,  

7. Następnie, na podstawie klasyfikacji Robertsona, zostanie utworzony profil roboczy i 

warstwy obliczeniowe (create assumed layers from Classificatin soilbar),  

8. Warstwy cieńsze niż 0.1 m zostaną usunięte - Automatyczne usuwanie cienkich warstw 

(automatic elimination of thin layers). Wstawki cienkich warstw mogą być usuwane na 

dwa sposoby: Połowa zostanie połączona z warstwą powyżej, a połowa z warstwą 

poniżej. Usuwana warstwa bada rodzaj gruntu w warstwie wyższej oraz niższej, po czym 

łączy ją z warstwą o tym samym rodzaju gruntu (spoiste do spoistych a piaszczyste do 

piaszczystych) 

9.  W następnej kolejności wybieramy metody obliczeniowe parametrów gruntów w 

kolejności jakiej mają zostać użyte (w tym przykładzie zostaną policzone parametry ID, 

IL oraz Fi’). Można użyć metod standardowych „wbudowanych” w oprogramowanie 

CPT-Star jak i formuł zdefiniowanych przez użytkownika. 

10. Zaokrąglij Głębokości spowoduje ustawienie precyzji głębokości do 0.1 m 

Grupa formuł może zostać zachowana do pliku, a także opcjonalnie dołączana do pliku danych 

CPT w celach archiwizacji użytych metod jak i przekazana innym użytkownikom programu. 

 

Aby ustawić możliwość zapisu formuł i grup formuł wraz z plikiem danych oraz ich 

wczytywanie należy wybrać Options, a następnie w okienku poniżej wybrać odpowiednie opcje 

w ramkach Save with datafile oraz Load with datafile 
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Rys. 3.2. Wybór opcji zapisu formuł programu lub użytych grup formuł wraz z plikiem danych 
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12. NOWE OPCJE OPROGRAMOWANIA DO INTERPRETACJI 

SONDOWAŃ STATYCZNYCH CPT-STAR -2 PROFESSIONAL 

12.1. WSTĘP 

 

Do najnowszej wersji oprogramowania CPT-STAR dodano szereg zmian i ulepszeń w stosunku 

do wersji wcześniejszej. W wersji wcześniejszej warstwy były często wydzielane na podstawie 

klasyfikacji parametrycznej na podstawie charakterystyk (np. metody. Robertsona, 

Schmertmanna). Często niewłaściwa klasyfikacja gruntów byłą przyczyną błędów.  

W aktualnej wersji do wydzieleń warstw profilu roboczego można wykorzystać profil 

porównawczy tzn. znany profil znajdujący się w niezbyt dużej odległości od profilu badanego.  

 

Najważniejsze zmiany to: 

 

 Wydzielanie warstw profilu na podstawie profilu porównawczego oraz równoległy jego 

podgląd wraz z profilem roboczym (badawczym) 

 Manualne - na wykresach, korygowanie wartkości średnich parametrów warstw poprzez 

ich przesuwanie myszką 

 Ulepszona i rozbudowana o dodatkowe opcje tabela warstw gruntów. 

 Poprawiono i rozbudowano definiowanie metod własnych użytkownika. 

 Uniezależniono wykonywanie algorytmów od klasyfikacji parametrycznej na podstawie 

charakterystyk (nomogramów) 

 Ulepszono współpracę z programem GeoStar w tym dodano opcję wczytywania 

istniejącego profilu GeoStar jako profilu porównawczego. 

 Dodano szablony dla wielostronicowych dokumentów 

 Dodano generowanie raportów 

 Inne drobne korekty i ulepszenia 

 

12.2. WYDZIELANIA WARSTW PROFILU 

 

W celu dalszej identyfikacji wprowadzono do terminologii trzy rodzaje profili 

4. Profil roboczy 

5. Profil porównawczy 

6. Profil z klasyfikacji parametrycznej na podstawie charakterystyk (menu Klasyfikacja) 

Profil roboczy to profil aktualnie tworzony, którego parametry należy policzyć. Profil 

porównawczy to profil o znanej litologii znajdujący się w pobliżu profilu roboczego. Profil 

roboczy tworzony jest poprzez porównanie jego wykresów sondowania z litologią profilu 

porównawczego. Profil klasyfikacji parametrycznej z charakterystyk to profil, którego litologia 

została określona wyłącznie na podstawie parametrów sondowania przy pomocy nomogramów 

Robertsona, Schmertmanna lub podobnych. Profil ten uzyskuje się po wyborze z menu 

Klasyfikacja → Wykonanie klasyfikacji ciągłej na podstawie charakterystyk i może w 

szczególnych przypadkach służyć jako pomocniczy. 

W oknie programu może istnieć wyłącznie profil roboczy lub kombinacja dwóch profili. 

Poniżej pokazano sposób wyboru profili z menu Widok lub z naciśnięciu przycisku Widok  
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Rys. Wybór rodzaju profili z Menu 
 

Na rysunku obok wykresu domyślnie rysowany jest profil roboczy, jednak możliwe jest 

wyrysowanie dodatkowo profili: 

 Profil porównawczy 

 Profil uzyskany na podstawie charakterystyk. 

 Rysunek innego profilu skopiowany poprzez schowek na zasadzie Kopiuj → Wklej. Jego 

pokazaniu służy menu Widok → Rysunek porównawczy. 

 

Dane do profilu porównawczego można uzyskać z kilku źrodeł. 

4. Z danych otworu bazy danych GeoStar.  

5. Z innego profilu CPT wykonanego wcześniej 

. 

Profil porównawczy można uzyskać z profilu znajdującego się w programie GeoStar poprzez 

Menu Profil porównawczy →Wczytaj z bazy GeoStar (lub z Menu Plik → Importuj Warstwy z 

bazy danych GeoStar → Jako profil porównawczy). 

 

Na okienku dialogowym wybieramy z listy właściwy profili i zaznaczamy, czy będzie to profil 

porównawczy. W przeciwnym wypadku zaimportowany profil będzie jako profil roboczy. 

Można także wczytać profil porównawczy jako roboczy i nastanie zmodyfikować go. Jeśli profil 

porównawczy i roboczy leżą na innych rzędnych można oba profile ustawić na odpowiednej 

wysokości poprzez wybranie Ustaw wg rzędnych zadanych 
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Rys. Wczytanie profilu porównawczego/roboczego z bazy danych GeoStar 

 

Aby uzyskać rysunek porównawczy z innego profilu wykonanego programem CPT należy 

skopiować go poprzez wybór Menu Edycja → Kopiuj profil roboczy jako rysunek. Następnie po 

wczytaniu danych nowego, interpretowanego profilu wybieramy Edycja → Wklej rysunek jako 

rysunek porównawczy. 
 

 

 

Poniżej pokazano wydzielanie warstw na profilu roboczym przy pomocy profilu 

porównawczego. Edycja głębokości wydzieleń profilu roboczego możliwa jest po wybraniu z 

Menu Warstwy → Ręczna zmiana warstw gruntów lub ikony: 

 

 
 

Wybranie z submenu Podziel umożliwia podział warstwy lub dodanie nowej zakończającej.  

Pojawia się wtedy pozioma linia podziału na głębokości wskazanej myszką. Wybranie Usuń 

usuwa wskazaną warstwę umożliwiając jej przyłączenie do górnej lub dolnej.   
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Rys. Profil porownawczy i profil roboczy na jednym rysunku 
 

12.3. MANUALNE USTAWIANIE CECH WARSTW 

 

Nacisnięcie warstwy na słupku Profilu roboczego spowoduje ukazanie się okienka 

umozliwiającego wprowadzenie jej cech:  

 Litologii i symbolu gruntu ze słownika wraz z unikalnym kodem klasyfikacji. 

 Rodzaju gruntu (piaszczysty, spoisty, organiczny) 

 Podgląd i wyliczenie parametrów warstwy wg zadanej formuły 

Przy wprowadzaniu litologii i symbolu gruntu korzysta się ze słowników gotowych lub 

modyfikowanych przez użytkownika. Każda pozycja ze słownika posiada unikalny Kod 

klasyfikacji. Kod ten jest wybierany automatycznie po wyborze pozycji ze słownika i umożliwia 

przyporządkowanie warstwy do metody obliczeń. 
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Rys. Po naciśnięciu warsty na słupku pojawia się okienko słownika 

 

 

Na wykresie widoczne są dwie linie – wartości średnich warstw (o ile zostaną wcześniej 

policzone) oraz wykres wielopunktowy pomiarów z kanału sodnowania. W każdej chwili, 

klikajac warstwy, można nadać i zmienić jej klasyfikację. 

 

12.4. SŁOWNIKI LITOLOGICZNE KLASYFIKACJI GRUNTÓW 

 

Przy klasyfikacji można używać następujacych słowników: 

 Lokalny zgodny z ISO14688-2 

 Lokalny zgodny z DIN 18196 

 Lokalny zgodny z GeoStar 

 Bezpośrednio dostępny z oprogramowania GeoStar 

 Słownik zdefiniowany indywidulanie przez użytkownika 

 

Wybór słownika odbywa się z Menu Format –> Ustawienia słowników 

Oprogramowanie wykorzystuje słownik bieżący oraz słownik domyślny.  

Słownik bieżący to słownik, który wykorzystano wcześniej do klasyfikacji wczytanego profilu. 
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Słownik domyślny to słownik, który będzie domyślnie użyty do nowo opracowywanych 

sondowań.  

 
Rys. Wybór słownika klasyfikacji gruntów 

 

 

 
Rys. Słownik zgodny z ISO14688-2 
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12.5. MANUALNE KORYGOWANIE WARTOŚCI ŚREDNICH 

PARAMETRÓW WARSTW 

 

 

 
 

Na wykresach parametrów mogą rysowane dwie linie: 

 

 jedna łamana z wartościami pomiarów kanałów sondowania,  

 druga wyliczonych wartości średnich 

 

 

Aby możliwa była manualna korekta wartości średnich parametru dla warstw należy: 

 

1. Wcisnąć ikonkę ustawiania wartości średnich warstw (wskazana na górnym pasku zadań) 

2. Wybrać myszką odcinek edytowanej średniej 

3. Po ukazaniu się okienka Wartość parametru dla Warstwy – skorygować Wartość 

 

12.6. DOSTOSOWANIE RZĘDNYCH PROFILI 

 

Importując profil porównawczy, np. z programu GeoStar, należy zważyć by rzedną profilu 

porównawczego odpowiednio korelowała z rzędną profilu roboczego. W tym celu wczytując 

profil porównawczy z GeoStar, należy na okienku dialogowym importu zaznaczyć Ustaw 

według rzędnych zadanych. 
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Przesunięcie profilu, do zadanej rzędnej, jest możliwe także z dialogu Opcje wykresu i kanały. 

 

 

12.7. ZMIANA JEDNOSTEK MPa → Kpa 

 

Na samym wykresie możliwe jest auto skalowanie zakresu osi, jak i zmiana jednostek MPa na 

Kpa. Pokazano to na poniższym rysunku. Zmiana jednostek dotyczy wyłącznie rysunku. 

 



56 

 

 
 

Oczywiście wewnętrznie i przy wszelkich obliczeniach program korzysta w dalszym ciągu z 

MPa. Sama zmiana jednostki dotyczy jedynie wykresu. 

 

12.8. WZORY WŁASNE – OBLICZANIE NOWYCH PARAMETRÓW NA 

PODSTAWIE DANYCH KANAŁU LUB WYLICZONYCH WARTOŚCI 

ŚREDNICH WARSTW INNYCH PARAMETRÓW 

 

 
 

 

Obliczanie parametrów warstw odbywa się na podstawie wartości: 

 

1. Z kanałów (najpierw liczone są dyskretne wartości parametru z częstotliwością skoku 

pomiaru, a następnie wyniki są uśrednione dla warstwy gruntu) 
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2.  Średnich parametrów warstw gruntu wyliczonych wcześniej (operujemy wyłącznie 

średnimi) 

 

Pokazano to na powyższym rysunku, gdzie zmienna może być parametrem warstwy lub 

wartością kanału. 

 

Zmienna pa1 oznacza uśredniony parametr warstwy o indeksie1. 

Zmienna Ch20 oznacza dane z kanału 20.  

 

 

 

Przy wyborze zmiennej dla przypadku 2 pojawia się okienko dialogowe: 

 

 

 
Na okienku opisano indeksy paramatrów warstw. Wykorzystanie metody drugiej pozwala np. na 

ręczną korektę prametru qc dla całej warstwy i nastepnie pozwala ten zmodyfikowany parametr 

wykorzystać do dalszych obliczeń innych jej parametrów.  

 

12.9. TWORZENIE TABELI WYNIKÓW 

 

Po wyliczeniu parametrów warstw profilu można przesłać je do karty otworu w aplikacji 

GeoStar lub wygenerować tabele parametrów geotechnicznych podłoża. W tym celu należy 

wybrać tabele wyników stanów gruntu, którą pokazano poniżej. 
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Następnie należy wyznaczyć, które kolumny należy pokazać w raporcie wyników. W tym celu 

wybieramy ikonkę Kolumny.  

 
 

 
Nr Strop 

warstwy 
Spag 

warstwy 
Symbol gruntu qc fs Rf qt ID IL 

  m m   MPa MPa % MPa   deg 

1 0.01 0.25 Du 0.514 0.006 1.338 0.514  0.827  

2 0.25 0.52 Pip//Pii 1.798 0.021 1.143 1.796 0.037  30.000 

3 0.52 0.88 Ppi 1.270 0.031 2.396 1.270  0.432  

4 0.88 1.21 I 0.583 0.024 4.229 0.582  0.588  

5 1.21 1.56 Ppi//Pip 5.544 0.058 1.052 5.520 0.283  35.520 

6 1.56 2.23 P//Ppi 9.028 0.104 1.173 9.003 0.467  39.003 

7 2.23 2.43 Ppi 1.787 0.058 3.319 1.767  0.534  

Tutaj w kolumnie Drukowana zazna-

czamy parametry, które pragniemy 

pokazać w tabeli wyników. 

Po ich zaznaczeniu można wydru-

kować tabele wyników w formie 

uproszczonej, po naciśnięciu ikony 

Drukuj, lub po naciśnięciu ikony 

Kopiuj skopiować, a następnie wkleić 

do edytora tekstowego np. Word jako 

HTML. Pokazano to w dalszej części 

na rysunku. Parametry wklejone są do 

edytora jako tabela, której zawartość 

można dalej edytować tzn. zmieniać 

zawartość i dostawiać kolumny oraz 

opisy 

 
 

Rys. Wybór drukowanych (raportowanych) 

parametrów 
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8 2.43 2.77 O 0.246 0.040 15.491 0.229    

9 2.77 3.06 I 0.299 0.009 3.274 0.282  0.873  

10 3.06 3.56 P 12.743 0.095 0.733 12.728 0.584  41.364 

11 3.56 4.16 P 15.857 0.158 0.995 15.845 0.685  42.922 

12 4.16 4.38 P//Ppi 14.359 0.164 1.142 14.347 0.655  42.174 

13 4.38 4.90 Du.zw. 15.666 0.152 0.968 15.654  0.000  

14 4.90 5.70 P 16.235 0.149 0.916 16.224 0.691  43.112 

15 5.70 6.20 P 21.669 0.191 0.883 21.662 0.769  45.000 

16 6.20 6.42 P//Ppi 19.607 0.292 1.487 19.600 0.751  44.800 

17 6.42 7.00 P 16.857 0.162 0.959 16.851 0.702  43.426 

18 7.00 7.27 P 13.997 0.132 0.943 13.993 0.649  41.996 

19 7.27 7.55 P//Ppi 11.308 0.131 1.179 11.303 0.431  40.652 

20 7.55 7.87 Ppi//Pip 9.997 0.160 1.604 9.993 0.448  39.993 

21 7.87 8.10 P 13.342 0.128 0.959 13.335 0.617  41.667 

22 8.10 8.58 P 19.140 0.193 1.017 19.135 0.688  44.567 

23 8.58 8.86 I 3.143 0.173 5.511 3.134  0.170  

24 8.86 12.13 I 3.284 0.220 6.700 3.283  0.181  

25 12.13 13.08 I 3.484 0.199 5.720 3.482  0.162  

26 13.08 14.06 I 3.548 0.252 7.134 3.549  0.149  

27 14.06 14.48 I 5.024 0.297 5.911 5.025  0.033  

28 14.48 15.05 I 4.022 0.258 6.383 4.026  0.191  

           

 
Rys. Przykładowa tabela wyników parametrów geotechnicznych warstw podłoża po wklejeniu do etytora Word 

 

12.10. SZABLONY DOKUMENTÓW WIELOSTRONICOWYCH 

 

Często występuje potrzeba wydruku wyników w postaci wykresów wielu parametrów na kilku 

stronach, przy czym parametry i układ stron muszą być identyczne dla całej serii sondowań. 

Opcja ta dotyczy także zachowania do pliku PDF wszystkich utworzonych dokumentów 

dotyczących sondowania. 

W tym celu należy: 

1. Utworzyć szablon drukowania dokumentów i zachować go. 

2. Drukować poprzez wydruk szablonu. 

3. Zachowywać do pdf jako Eksport do pdf kompletu dokumentów 

 

Tworzenie szablonu 

 

Należy z menu Format wybrać opcje Szablon kompletu dokumentów. Ukaże się okienko 

dialogowe: 
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Rys. Okienko tworzenia szblonu drukowania dokumentów 

Tworząc szablon należy: 

 Zaznaczyć z ilu dokumentów ma się składać dokumentacja sondowania 

 Wybrać wykresy kanałów dla poszczególnych dokumentów 

 Zachować szablon.  (Save as default spowoduje, że aż do zmiany, będzie to szablon 

domyślny). 

 

Podglądu dokumentów zgodnie z szablonem można dokonać poprzez wciśniecie ikonki Widok. 

Na okienku narzędziowym Widok Zaznaczamy Dokument wg Szablonu i wybieramy numer 

dokumentu. 
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Rys. Okienko widoku dokumentów 

 

Drukowanie wg szablonu 

 

Aby wydrukować zestaw dokumentów sondowania zgodnie z szablonem należy wybrać Drukuj i 

zaznaczyć wg. Szablonu 

 

 

Rys. Okienko tworzenia szblonu drukowania dokumentów 

Aby zachować wszystkie dokumenty szablonu do pliku PDF należy wybrać Plik → Eksportuj do 

PDF komplet dokumentów 

Uwagi: 1. Wersja Standard nie zawiera szablonów.  Występują one w wersji Profesional 

2.Szablony sondowań zachowywane są wraz z wynikami interpretacji. 
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12.11. TWORZENIE RAPORTÓW 

 

Wyniki obliczanych parametrów warstw mogą być generowane w postaci tabelarycznej przez 

oprogramowanie jako raporty. Przykład tworzenia raportu pokazano poniżej. 

 

Rys. Edycja raportu 

Raport generowany jest przez oprogramowanie w osobnym okienku edycyjnym o interfejsie 

zbliżonym do edytorów Office. 

Tworzenie szablonu raportu 

Obsługa raportów odbywa się z menu Raporty. Aby raport mógł być wygenerowany, powinien 

zostać utworzony jego szablon (Szablon raportu) określający jakie parametry warstw powinny 

znaleźć się w tabeli raportu. Jeśli pod raportem pragniemy umieść dodatkową tabelkę z danymi 

wykonawcy, lokalizacji profilu itp.  to należy wcześniej wykonać jej szablon edytorem 

załączonym do oprogramowania lub innym np. Word i zachować go w formacie RTF. 

Użytkownik może także wykorzystać wcześniej opracowane własne tabelki. Tabelka taka będzie 

automatycznie dołączana pod raportem. 

 

Okienko szablonu tabeli raportu pokazano to na rysunku poniżej. 

W celu prawidłowego utworzenia i korzystania z szablonu należy: 

 Na liście Parametry raportu zaznaczyć te kolumny tabeli, które powinny znaleźć się w 

raporcie 

 Wskazać plik szablonu tabelki pod raportem w formacie RTF 

 Zachować szablon jako domyślny 

 Nacisnąć przycisk akceptuj. 

Przycisk Pokaż demonstruje podgląd tabeli raportu wg tworzonego szablonu. Zamiana 

szerokości kolumn zmienia także ich szerokość na dokumencie wygenerowanego raportu. 
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Rys. Tworzenie szablonu raportu 

 

Raport można Utworzyć od nowa, dodać własny opis i uwagi, a następnie zachować. Ot tej pory 

będzie on składową częścią wyników każdego sondowania, wczytywaną po każdym ponownym 

otwarciu sondowania.  

 

Jeśli raport został już utworzony i zachowany można ponownie go otworzyć wybierając z Menu 

Raporty → Wczytaj ostatni. Raporty można uzupełniać dodając własne treści i ponownie 

zachowywać. 
 

Raporty można drukować lub zachowywać do PDF lub poprzez schowek kopiować do innych 

opracowań 
 

12.12. ZACHOWYWANIE I OTWIERANIE DOKUMENTÓW. 

Miejsce zachowywania dokumentów 

Możliwe są dwa tryby pracy: 

1. Z dokumentami zachowywanymi w plikach na dysku (tryb tradycyjny) 

2. Z dokumentami zachowywanymi w bazie danych GeoStar 

Domyślny, po starcie programu, jest tryb pierwszy. Aby przejść do trybu pracy na bazie danych 

należy wcisnąć ikonkę wskazaną na poniższym rysunku. 

 



64 

 

 
 

Spowoduje to ukazanie się, po prawej stronie okna, listy Profile w bazie. Aby profil znalazł się 

na tej liście należy, po imporcie sondowania i wykonaniu interpretacji i obliczeń parametrów, 

wybrać Zachowaj w bazie danych. Profile zachowane w bazie danych mogą być 

wykorzystywane przez oprogramowanie GeoStar 

 

Zakres informacji zachowywanych dokumentów 

Wraz z dokumentem zachowywane są zawsze informacje związane z sondowaniem  

1. Dane z sondy,  

2. Wykresy,  

3. Klasyfikacja gruntów uzyskana na podstawie nomogramów, 

4. Profil roboczy z wynikami obliczeń parametrów warstw, 

5. Raporty. 

 

Bardziej złożona jest sprawa użytych, zdefiniowanych przez użytkownika Formuł lub Grup 

formuł (makr). Domyślnie powinny one być zachowywane wraz z dokumentami sondowania, tak 

by w przyszłości, wczytując sondowanie można było do tych metod powrócić, 

W przypadku opracowywania dużej serii otworów, z wykorzystaniem tych samych formuł, 

korzystniejsza jest opcja pracy z formułami bieżącymi bez ich wczytywania wraz z każdym 

zachowanym sondowaniem Definicji formuł oraz Grupy formuł (makr). Wtedy oprogramowanie 

korzysta z bieżących formuł domyślnych. 

Sposób ustawiania zakresu zachowywanych i wczytywanych informacji pokazano na rysunku 

poniżej. 
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Zaleca się w opcji Zachowaj wraz z danymi i wynikami obliczeń, zaznaczyć Grupy formuł z 

definicjami (tak jak na rys. powyżej). 

 

Natomiast w ramce wyboru Wczytaj wraz z danymi i wynikami obliczeń wybrać opcje 

uwzględniającą wcześniejsze uwagi.  

 

W przypadku, gdy wybierzemy opcję pierwszą Tylko dane i wyniki obliczeń – pozostaną 

bieżące formuły domyślne programu, a nie te zachowane wcześniej wraz z sondowaniem. Na 

ogół będą się one pokrywać.  

Jeśli wybierzemy opcję drugą lub trzecią, a do formuł domyślnych została dodana nowa, to po 

wczytaniu sondowania zostaną przywrócone formuły zachowane z sondowaniem. 

Niezależnie od ustawień powyższych opcji podczas wczytywania sondowania na wszelki 

wypadek pokaże się okienko potwierdzające wybór.  

 
 

12.13. WPROWADZANIE KOMPLETU WYNIKÓW PARAMETRÓW WARSTW 

DO NOWEJ TABELI W BAZIE DANYCH GEOSTAR  

 

W oprogramowaniu GeoStar dodano tabelę GS_CPT_LAYERS umożliwiającą zachowywanie 

przez oprogramowanie CPT wyników obliczeń parametrów warstw. Pola tabeli mogą być 
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wykorzystywane w kartach otworu, na przekrojach, a także to tworzenia map izoliniowych na 

mapach GeoPlan.  

Odpowiednie okna w oprogramowaniu GeoStar pokazano to na rysunku poniżej. 

 
 

Tabela wyników CPT w bazie danych GeoStar 

 

Struktura GS_CPT_LAYERS zawiera następujące pola stałe. Nazwy pól podano w cudzysłowie 

    // kanały wyliczane jako parametry gruntu 

  Pola_CPT_Leayers[par_Id] := 'G_ID'; 

  Pola_CPT_Leayers[par_Il] := 'G_IL'; 

  Pola_CPT_Leayers[par_OCR] := 'G_OCR'; 

  Pola_CPT_Leayers[par_Fi] := 'G_FI'; // efektywny kat tarcia 

  Pola_CPT_Leayers[par_Mo] := 'G_MO'; // moduł odkształcenia   Comresion Modul 

  Pola_CPT_Leayers[par_Ko] := 'G_KO'; // 

  Pola_CPT_Leayers[par_SigmaPp] :=  'G_CIS_PREKON'; // naprezenie prekosolidacyjne 

  Pola_CPT_Leayers[par_St] := 'G_ST'; // wrazliwosc tylko P; 7.5/Rf 

  Pola_CPT_Leayers[par_Cprim] := 'G_SPOJNOSC'; // spojnosc 

  Pola_CPT_Leayers[par_Su] :=  'G_SU'; // Niedrenowana wytrzymałość na sciskanie 

  /// / Par_M = 21; // Moduł scisliwosci - Constrained Modul 

  Pola_CPT_Leayers[Par_Eoed] := 'G_EOED'; // Modul edometryczny 

 

 

 

Struktura GS_CPT_LAYERS zawiera następujące pola definiowane przez użytkownika 

  Pola_CPT_Leayers[par_User1] := 'USERDEF31'; 

  Pola_CPT_Leayers[par_User2] := 'USERDEF32'; 

  Pola_CPT_Leayers[par_User3] := 'USERDEF33'; 
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….. 

…... 

  Pola_CPT_Leayers[par_User19] := 'USERDEF49'; 

  Pola_CPT_Leayers[par_User20] := 'USERDEF50'; 

 

 

Poniżej pokazano tworzenie szablonu karty uniwersalnej zawierającej wyniki obliczeń warstw w 

tabeli GS_CPT_LAYERS. 
 

 
Szablon karty uniwersalnej GeoStar umożliwiający prezentacje wyników CPT 

12.14. IMPORT PLIKÓW W FORMACIE XLS 

12.14.1. Import plików w czystym formacie XLS 

Oprogramowanie CPT-Star posiada możliwość wczytywania plików Excel XLS. Format takiego 

pliku powinien być następujący: 

Wiersz pierwszy to nagłówki (symbole) kanałów przedzielone średnikami 

Kolejne wiersze to wartości kanałów dla kolejnych głębokości z tym, że kolumna 1 to wartość 

głębokości lub jej kolejny numer (przy zadanym skoku) Po wybraniu pliku XLS pojawi się okno 

jak poniżej: 
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Okno importu z pliku XLS 

W przypadku, jeśli arkusz, powyżej bloku danych, zawiera jakieś „śmieci” lub elementy 

ogólnych informacji o sondowaniu należy wybrać wiersz nagłówka a następnie „Usuń wszystkie 

wiersze powyżej. Przypadek taki pokazano na poniższym rysunku. 

 
 

12.14.2. Import plików xls utworzonych sondą Pagani (w formacie TGSA-08) 

Najnowsze sondy Pagani posiadają możliwość zachowywania wyników sondowania w formacie 

XLS. Jest to format niejako „skażony” gdyż powyżej bloku danych zawiera wiersze z 

informacjami ogólnymi o sondowaniu, podzielone na bloki. 

 Company information: 

 Site information: 

 Test information: 
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Okno importu z pliku XLS w formacie sondy Pagani  

Aplikacja importując dane niejako sama uchwyci linię Zaczynającą się od Depth [m] i oznaczy 

ja jako początek danych. Niektóre informacje powyżej tej linii zostaną przepisane do informacji 

ogólnych o sondowaniu. 

Ze względu na to, że niektóre kanały mogą być wyrażone w [KPa] należy zwrócić uwagę na 

jednostki kanałów. Kolejny dialog importu z opisem przeliczników jednostek pokazano poniżej.  

Po naciśnięciu Ok dane sondowania zostaną zaimportowane. 
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Okno mnożników  importu z pliku XLS z  sondy Pagani  

12.15. WPROWADZANIE MANUALNE SONDOWANIA STOŻKIEM 

MECHANICZNYM 

Po wyborze z menu Wprowadź nowe sondowanie stożkiem mechanicznym pojawi się edytor 

umożliwiający wprowadzenie wyników sondowania wykonanego stożkiem mechanicznym. 

Pokazano to poniżej: 
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Okno arkusza wprowadzania odczytów sondy ze stozkiem mechanicznym  

Istnieje możliwość wprowadzenia wg: 

1. Odczytów wprost z sondy parametrów RP oraz RP+RL 

2. Gotowych wartości Qc i Fs. Wartości te muszą być wprowadzane w [MPa] 

W przypadku opcji pierwszej po wprowadzeniu wartości RP oraz RP + RL należy wybrać 

przycisk Wylicz Qc i Fs.  

Po wprowadzeniu wartości należy nacisnąć przycisk OK i dane zostaną wprowadzone do 

programu. Po akceptacji wprowadzonych danych należy je zachować wybierając Zachowaj jako. 
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