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WSTĘP
Do najnowszej wersji oprogramowania CPT-STAR dodano szereg zmian i ulepszeń w stosunku do wersji wcześniejszej. W wersji wcześniejszej warstwy były często wydzielane na podstawie klasyfikacji parametrycznej na podstawie charakterystyk (np. metody. Robertsona, Schmertmana). Często niewłaściwa klasyfikacja gruntów byłą przyczyną błędów. 

W aktualnej wersji do wydzieleń warstw profilu roboczego pomocny jest profil porównawczy tzn. znany profil znajdujący się w niezbyt dużej odległości od profilu badanego. 

Najważniejsze zmiany to:

· Wydzielanie warstw profilu na podstawie profilu porównawczego oraz równoległy jego podgląd wraz z profilem roboczym (badawczym)

· Manualne - na wykresach, korygowanie wartkości średnich parametrów warstw poprzez ich przesuwanie myszką

· Ulepszona i rozbudowana o dodatkowe opcje tabela warstw gruntów.

· Poprawiono i rozbudowano definiowanie metod własnych użytkownika.

· Uniezależniono wykonywanie algorytmów od klasyfikacji parametrycznej z charakterystyk

· Ulepszono współpracę z programem GeoStar w tym dodano opcję wczytywania istniejącego profilu GeoStar jako profilu porównawczego.

· Inne drobne korekty i ulepszenia

1. INFORMACJE OGÓLNE

Pakiet CPT-Star jest, opracowanym w całości w kraju, programem komputerowym do dokumentowania badań gruntów wykonanych sondą statyczną, oferującym wykonanie wykresów zmierzonych parametrów oraz pełną klasyfikację rodzajów gruntu.   Program posiadający grafikę skalowaną oraz w pełni graficzne środowisko pracy i umożliwia także integracje (zachowanie danych, wprowadzenie wyników do bazy danych, kopiowanie wykresów na przekroje geologiczne) z programem GeoStar 6i Professional/Ultimate

Program wykonuje:

1. Prezentację wczytanych z sondy danych pomiarowych, 

2. Wylicza szereg parametrów użytecznych do oceny stanu gruntu,
3. Opcjonalnie wykonuje klasyfikacje rodzaju gruntów kilkoma opublikowanymi metodami, 

4. Opcjonalnie wczytuje klasyfikacje gruntów (litologię) z bazy danych GeoStar,
5. Oblicza parametry w sposób ciągły oraz średnie dla wyznaczonych warstw,
6. Eksportuje do bazy danych GeoStar wyliczone parametry warstw lub całą klasyfikację,
7. Eksportuje do arkusza Excel wyliczone parametry warstw wraz z klasyfikacją.
Program wczytuje dane z sondy pomiarowej ze stożkiem elektrycznym. Firma Soft-Projekt zapewnia, w miarę możliwości, dostosowanie programu do formatu danych tworzonych przez sondy różnych firm światowych.
Program zapisuje dane we własnym formacie. Parametry wejściowe z sondy, jak i obliczane przez program, zapisywane są w oddzielnych kanałach. Parametrom, wykorzystywanym do dalszych obliczeń, przyporządkowano stałe kanały, przydzielone przez producenta programu. Program ma do swojej dyspozycji 50 kanałów, co stwarza dużą rezerwę na przyszłość. Na Rys. 1 i 2 rozpisano kanały i przyporządkowane im parametry.

Rys. 1 Kanały standardowe z sondy i przeliczane programu CPT-Star – kanały 1-30

	Cha-

nnel
	symbol
	Phisical Value
	Formula
	Units
	Notes

	1
	qc
	Point resistance
	
	MPa
	

	2
	fs
	Sleeve friction resistance
	
	MPa
	

	3
	u2


	Pore pressure behind cone
	
	MPa
	

	15
	Rf
	Friction ratio
	
	%
	

	16
	u0
	Dissipation test result
	
	MPa
	if data not exists then zero

	17
	qt
	Corrected point resistence
	qt = qc + u(1 - a)
	MPA
	

	18
	ft
	Corrected local friction
	ft = fs - u * b
	MPA
	

	19
	vo
	Total overburden stress 
	vo(h) = hi * i(h)
	MPA
	i – density

	20
	vo’
	Effective total overburden str
	vo’ = vo – u0
	MPA
	u0 – dissipation result

	21
	qt - vo
	qt-sigmaVo
	qt - vo
	MPA
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22
	Qt
	Normalized cone resistance
	
	
	

	23
	Fr
	Normalized friction ratio
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	Bq


	Pore pressure parameter


	
	
	

	25
	Rf(qc)
	Friction ratio
	fs/qc*100%
	
	

	26
	u0
	Hydrostatic pressure
	
	MPA
	

	27
	Rfd
	Friction ratio (NEN5140)
	
	%
	

	28
	
	
	
	
	

	29
	
	
	
	
	

	30
	
	Soil bar classification No
	
	
	


where: 
a- probe area factor a

b- probe area factor b

Rys. 2 Wszystkie kanały CPT

	Channel
	Parameter
	Symbol
	Unit
	Precision

	1
	Point resistance
	qc
	MPa
	3

	2
	Sleeve friction resistance
	fs
	MPa
	3

	3
	Pore pressure behind cone
	u2
	MPa
	4

	4
	
	
	
	3

	5
	
	
	
	3

	6
	
	
	
	1

	7
	
	
	
	3

	8
	
	
	
	3

	9
	
	
	
	3

	10
	
	
	
	2

	11
	
	
	
	3

	12
	Czas
	t
	s
	3

	13
	Prędkość ondowania
	v
	cm/s
	3

	14
	
	
	
	3

	15
	Friction ratio = ft/qt*100%
	Rf
	%
	3

	16
	Dissipation
	Uo
	MPa
	3

	17
	Corrected point resistance
	qt
	MPa
	3

	18
	Corrected local friction
	ft
	MPa
	3

	19
	Total overburden stress 
	sigmaVo
	MPa
	3

	20
	Effective total overburden str
	sigma'Vo
	MPa
	3

	21
	qt-sigmaVo
	qt-sigmaVo
	MPa
	3

	22
	Normalized cone resistance
	Qt
	
	3

	23
	Normalized friction ratio
	Fr
	%
	3

	24
	Pore pressure parameter
	Bq
	
	4

	25
	Friction ratio = fs/qc*100%
	Rf(qc)
	%
	3

	26
	Hydrostatic pressure
	Uh
	MPa
	3

	27
	Friction ratio (NEN5140)
	Rfd
	%
	3

	28
	
	
	
	3

	29
	
	
	
	3

	30
	Wynik klasyfikacji
	grunt
	
	0

	31
	Relative Density ID
	Id
	
	3

	32
	Plasticity index Il
	IL
	
	3

	33
	Efektywny kt tarcia (Effective friction angle)
	Fi’
	deg
	3

	34
	Sume Rf
	Sum(Rf)
	%
	2

	35
	Sume Qc
	Sum(Qc)
	MPa
	2

	36
	Rf (medium in range)
	Rf med
	%
	3

	37
	Qc (medium in range)
	Qc med
	MPa
	3

	38
	
	
	
	2

	39
	
	
	
	2

	40
	
	
	
	2

	41
	
	
	
	2

	42
	
	
	
	2

	43
	
	
	
	2

	44
	
	
	
	2

	45
	
	
	
	2

	46
	
	
	
	2

	47
	
	
	
	2

	48
	
	
	
	2

	49
	Identyfikator metody klasyfika
	IDKlas
	
	0

	50
	Ground name Code / Kod szrafury
	Szraf.
	
	0

	51
	Nm
	Nm
	
	3

	52
	OCR
	OCR
	
	2

	53
	Koefficient of earth pressure 
	Ko
	
	3

	54
	Commpresion modulus / Modu odksztacenia 
	Mo
	MPa
	3

	55
	Napreenie prekonsolidacyjne
	sigma'p
	
	3

	56
	Constrained modulus / Modu odksztacenia (constrained modul
	M
	MPa
	3

	57
	Undrained shear strength / Niedrenowana wytrzymaołość
	Su
	MPa
	3

	58
	Moduł edometryczny
	Eoed
	MPa
	3

	59
	
	
	
	0

	60
	
	
	
	0

	61
	
	
	
	0

	62
	
	
	
	0

	63
	
	
	
	0

	64
	
	
	
	0

	65
	
	
	
	0

	66
	
	
	
	0

	67
	
	
	
	0

	68
	
	
	
	0

	69
	
	
	
	0

	70
	
	
	
	0


Program dostosowywany jest do sondy umożliwiając wczytanie danych z kilku rodzajów sond ze stożkiem elektrycznym. Niezależnie wczytane i przetworzone dane można zachować we własnym formacie programu, gdzie oprócz danych z sondy, zachowywane są klasyfikacje gruntów i wyliczane parametry. 

Dane sondy wczytywane są z plików sondy poprzez import. Przy wyborze pliku należy oznaczyć odpowiednio producenta sondy. Program do obliczeń wykorzystuje jako jednostkę ciśnienia [MPa], natomiast sondy różnych producentów zachowują dane w różnych jednostkach. Z tego powodu, podczas importu danych z sondy, dane są przemnażane przez współczynniki do [MPa]. 

2. Działanie pakietu i jego wykorzystanie

2.1. Działanie

Praktycznie przy pomocy pakietu CPT można wykonać całą część graficzną dokumentacji sondowań statycznych oraz uzyskać dane konieczne do wykonania części opisowej. Wykonywanie dokumentacji odbywa się etapami, wykorzystując kolejno odpowiednie moduły.

Zadaniem modułu jest odczytanie danych pomiarowych z plików zachowanych wyników sondowań, klasyfikacja gruntów wg ich rodzajów. W efekcie użytkownik uzyskuje rysunek, na którym utrzymuje słupek z litologią badanego gruntu oraz wykresy z wybranymi parametrami jakościowymi, a w szczególności danych odczytanych z sondy.  Wyniki mogą być przedstawione:

w sposób analityczny – bez wydzielania warstw, parametry wczytane i przetwarzane są w sposób ciągły w funkcji głębokości

w sposób syntetyczny (menu Layers) -  wydzielane są warstwy, przeprowadza się klasyfikacje gruntów i dla tych warstw i oblicza parametry średnie. Dodatkowo obliczane jest odchylenie standardowe i przedział ufności obliczonych parametrów.

Wejściowe dane pomiarowe, z sondy ze stożkiem elektrycznym, zapisywane są na ogół w postaci trzech parametrów do trzech kanałów:

1 – Point resistance – qc,
2 – Local friction – fs,
3 – Pore pressure – u,
Niezależnie należy wprowadzić wyniki testów dyssypacji, poziom wody gruntowej, a w przypadku podwiertu (predriling) jego głębokość i gęstość gruntu w obszarze podwiertu. W pierwszej kolejności obliczane są parametry wykorzystywane najczęściej do interpretacji metodami „klasycznymi”. 

Parametry stanu gruntu liczone są w warstwach po wybraniu odpowiedniej opcji z menu Layers programu. Warstwy wyznacza się:

1. Manualnie,
2. Na podstawie zintegrowanych w programie metod klasyfikacji,
3. Poprzez pobranie litologii z oprogramowania GeoStar,
 Oprogramowanie zawiera kilka zintegrowanych graficzno-numerycznych metod klasyfikacji rodzajów gruntu:

· metoda Robertsona z 1986 roku

·    metoda Robertsona z 1992 roku

·    metoda Schmertmanna

·    Wg Polskiej Normy – adaptacja nomogramu Mara

Często stosowana jest metoda opublikowana przez Robertsona 1986. Metodę tę wraz z materiałami źródłowymi pokazano na rysunkach 2.1 oraz 2.2 
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	Zone
	Soil Behaviour Type
	Zone
	Soil Behaviour Type

	1
	Sensitive fine grained
	7
	Silty sand to silty clay

	2
	Organic material
	8
	Sandy silt to clayey silt

	3
	Clay
	9
	Sand

	4
	Silty clay to clay
	10
	Gravely sand to sand

	5
	Clayey silt to silty clay
	11
	Very stiff fine grained   *

	6
	Sandy silt to clayey silt
	12
	Sand to clayey sand       *


Rys. 2.1. Metoda klasyfikacji gruntów opracowana przez Robertsona w 1986 roku.

Robertson, P.K., Campanella, R.G., Gillesie, D. And Greig, J. Use of piezometer cone data. Proceedings of the ASCE Specialty Conference in Situ ’86: Use of In Situ Tests in Geotechnical Engineering. ASCE. 1986.
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	Zone
	Soil Behaviour Type
	Zone
	Soil Behaviour Type

	 1
	Sensitive, fine grained
	6
	Sands; clean sand to silty sand

	2
	Organic soils-peats
	7
	Gravely sand to sand

	3
	Clays; clay to silty clay
	8
	Very stiff sand to clayey sand

	4
	Silt mixtures; clayey silt to silty clay
	9
	Very stiff fine grained

	5
	Sand mixtures; silty sand to sandy silt
	


Rys. 2.2. Metoda klasyfikacji gruntów opracowana przez Robertsona w 1990 roku. 

Robertson, P.K. Soil classification using the cone penetration test. Canadian Geotechnical Journal. 1990.
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Rys. 2.03. Metoda klasyfikacji gruntów wg Polskiej normy (adaptacja nomogramu Marra). 

Wyniki klasyfikacji przedstawiane są obok wykresów wraz ze słupkiem ciągłym (Continuos). 
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Rys. 2.04. Metoda klasyfikacji gruntów wg Polskiej normy (adaptacja wykresu Robertsona). 

2.2. Ustawienia i opcje 

Aby moc korzystać z pakietu w formie i zakresie odpowiadającym użytkownikowi należy ustawić pewne opcje i parametry

2.2.1. Parametry ogólne programu
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 Parametry ogólne wybieramy z menu Format → Options. Na panelu występuje kilka zakładek.  Można zachowywać wszystkie kanały co jest zalecane lub wybrane, gdy np. nie chcemy udostępniać niektórych wyników.

Rys. 2.2. Zakładka ogólne

2.2.2. Język
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Język tworzonej dokumentacji wybieramy z menu Format → Options → Zakładka Language. Wybór języka determinuje nazwy warstw litologicznych tworzonych podczas klasyfikacji jak i nazwy pól w tabelce opisu rysunku

Rys. 2.3. Zakładka wyboru języka

2.2.3 Import

Zakładkę import omówiono w rozdziale 3 przy okazji omawiania importu danych z sond różnych producentów

2.3. Zakresy i kolory kanałów 

Program umożliwia ustawienie zakresu i koloru kanałów na wykresie. W tym celu wybieramy z menu Format → Channels Color and range. Powoduje to pojawienie się panelu;
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Rys. 3.6. Okienko dialogowe ustawiania zakresu i koloru kanałów na wykresie

Jeśli włączymy Autoscale komputer sam dobierze zakresy wyłącznie na kanałach oznaczonych w kolumnie Autoscale. Kolory dobieramy klikając w kolumnie kolor na odpowiedni wiersz. Spowoduje to ukazanie się okna wyboru koloru.

3. PRACA Z PROGRAMEM BEZ WYDZIELANIA WARSTW
3.1. Wczytanie danych z sondy
Dane sondy wczytywane są z plików sondy poprzez File → Import. Po zachowaniu sondowania sondowanie wczytuje się w formacie własnym poprzez File → Open. Importując dane z sondy przy wyborze pliku należy odpowiednio wybrać producenta sondy. 

Program do wykonania wszelkich obliczeń wykorzystuje jako jednostkę ciśnienia [MPa], natomiast sondy różnych producentów wczytywane są w różnych jednostkach. A tego powodu podczas importu danych z sondy dane są przemnażane przez współczynniki. Współczynniki domyślne zadane są przez program, ale mogą być skorygowane przez użytkownika. Odbywa się to poprzez Format → Options. Następnie należy wybrać zakładkę Import i zaznaczyć rodzaj sondy. Pokazano to na poniższym rysunku.
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Wprowadzone współczynniki są automatycznie zachowywane w pliku konfiguracyjnym. Dane z sondy po zaimportowaniu należy zachować w formacie własnym oprogramowania CPT. W tym celu wybieramy Plik → Zapisz jako (File → Save as). W celu późniejszego wczytania zachowanych danych wybieramy File→Open i wczytujemy sondowanie. Po wczytaniu pojawia się okienko z wyborem kanałów. 

Alternatywnie dane robocze mogą zostać zachowane i odczytywane z bazy danych GeoStar. Jest bardzo wygodne, gdyż dane grupowane są tematami opracowań, a także zapobiega to tworzeniu na dysku ogromnej liczby plików. Współpracę z GeoStar opisano w rozdziale 7.

W miarę rozwoju oprogramowania Ilość importowanych typów sond stale się zwiększą oraz ze względu na to, że niektórzy producenci czasami zmieniają format zapisu istnieje możliwość dostosowania procedur importu do formatu pliku danych sondy posiadanej przez użytkownika  
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Rys. 3.1 Okienko z wyborem kanałów w trybie pojedynczym (Single)
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Rys. 3.1 Okienko z wyborem kanałów w trybie wielokanałowym

.

Po wyborze kanałów pojawi się wykres zawierający wykresy wczytanych kanałów oraz wyliczany kanał Rf. 
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Rys. 3.2. Wykres wczytanych kanałów CPT

3.2. Klasyfikacja gruntów na podstawie charakterystyk
3. Aby wykonać klasyfikację wczytanych gruntów należy wybrać z menu Clascification → Execute classification. Pojawi się wtedy okienko:
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Rys.3.3. Okienko wyboru metody klasyfikacji

W następnej kolejności pojawi się okienko z ciężarami gruntów które można zmodyfikować.


[image: image9]
Rys. 3.4. Okienko ciężarów gruntu dla wybranej metody klasyfikacji

Klasyfikacja przebiega dwutorowo. Najpierw wykonywana jest metoda Robertsona z 1986 roku i przeprowadzana jest wstępna klasyfikacja celem wyznaczenia klasyfikacji wstępnej. Jest to konieczne by ustalić gęstość gruntów. Następnie przeprowadzona jest klasyfikacja właściwa w której używa się wprowadzonych na rysunku 3.4 ciężarów gruntu. W wyniku klasyfikacji uzyskujemy rysunek słupka litologicznego obok wybranych wcześniej wykresów. Czasem klasyfikacja wykazuje znaczną ilość bardzo cienkich kilkumilimetrowych warstw. Aby je usunąć należy wybrać. Narzędzia → Eliminacja cienkich warstw i wskazać grubość najcieńszej warstwy. Warstwy cieńsze zostaną podzielone w połowie pomiędzy warstwą górną i dolną.
Uwaga: Wykonanie klasyfikacji gruntu tę metodą nie jest utworzeniem warstw obliczeniowych (Layers) a jedynie obrazkiem wyniku klasyfikacji, mogącym w dalszej części posłużyć do utworzenia warstw obliczeniowych, który tworzymy poprzez Layers → Create from classificatin bar
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Rys. 3.5. Przykład interpretacji gruntów nasypowych pierwszą metodą Robertsona po wyeliminowaniu przez program cienkich warstw.

3.3. Przenoszenie wykresów na przekrój programu GeoStar

Aby nanieść wykres sondowania CPT na przekrój wykonany programem GeoStar należy:

· Uruchomić aplikacje przekroje pakietu GeoStar i wybrać/utworzyć przekrój, na który mają być naniesione wykresy sondowania CPT

· Uruchomić program CPT i utworzyć konieczne wykresy w tej samej skali pionowej co przekrój GeoStar.

· Wybrać z menu Edycja → Kopiuj specjalnie → Wykres 1...3

· Powrócić do aplikacji przekroje i wskazujemy miejsce koło słupka litologicznego, gdzie ma być wklejony wykres.

· Po wklejeniu tak ustawiamy górę wykresu by zgadzała się z głębokością zero na słupku przekroju. 

· Klikamy na wklejony wykres i korzystając z prawego przycisku myszy wybieramy z menu kontekstowego Zakotwicz.

· Szerokość wykresu możemy zmniejszyć klikając na wykres i korzystając z prawego przycisku myszy wybieramy z menu kontekstowego Edytuj graficznie.   Następnie "chwytamy" punkt edycyjny z lewej lub prawej strony wykresu.

Tak utworzony przekrój możemy zachować. W wersji Profesional i Ultimate GeoStar wczytuje wykres sondowania z menu Wstaw→Sondowanie CPT
3.4. Wypełnienie tabelki

Tabelkę edytujemy wybierając z menu Format → Tabelka. Spowoduje to ukazanie się okienka dialogowego:

[image: image11.png]Tabela danych 4

Tyt Wik sondowania stalycznego CFTU

Nrtestu PZ52d4/Ms4 Wpdhizgdna X ¥: H

Korirahert Tester

nwestor Dais Skals
GEDS 010518 1:100
Otiekt Pic
Fzszit Dermo 50148
Lokslizcia Nesosks: Rysuek e
Autostsda A1 -ODCINEK & ME 103 1

Tabels widoczna (7] Uzywai dla biezaeo impartawanych testow

B Kori

[ Tabela uproszezona

[Logo imy 5 wee

X e | [ 0K





Rys. 3.7 Okienko dialogowe edycji tabelki

Raz wprowadzone do tabelki dane można wykorzystać w innych testach. W tym celu po wprowadzeniu danych do tabelki wciskamy przycisk Kopiuj. Po wczytaniu innego testu należy nacisnąć przycisk Wklej. Istnieje możliwość bezpośredniego dopisywania wprowadzonych do tabelki danych do kolejnych importowanych sondowań poprzez wybranie It use recently imported tests. 
3.5. Wyprowadzanie wyników

Rysunek sondowania może zostać wydrukowany. W tym celu należy najpierw wybrać drukarkę i format papieru drukarki poprzez wybór z menu Ustawienia drukarki a następnie Drukuj lub ikonkę drukarki na pasku zdań.

Rysunek można zachować do pliku w formacie PDF poprzez wybór z Menu Export do PDF 

4.WYDZIELANIE WARSTW
Wydzielenie i klasyfikacja warstw są konieczne, aby policzyć parametry gruntów. Inaczej liczone będą warstwy spoiste a inaczej piaszczyste. W pierwszym etapie wydzielamy przeloty (stropy-spągi) warstw. W drugim klasyfikujemy je przypisując określone cechy. Czasem obie te czynności są łączne

Po wydzieleniu warstw pojawi się słupek litologiczny. Po jego lewej stronie paskiem żółtym oznaczone będą warstwy piaszczyste a różowym warstwy spoiste. 

Warstwy można wydzielić manualnie obserwując Rf lub skorzystać ze zintegrowanej klasyfikacji gruntów lub też zaimportować litologie wprowadzonego profilu z oprogramowania GeoStar.

W celu dalszej identyfikacji wprowadzono do terminologii trzy rodzaje profili

1. Profil roboczy

2. Profil porównawczy

3. Profil z klasyfikacji na podstawie charakterystyk

Profil roboczy to profil aktualnie tworzony, którego parametry należy policzyć. Profil porównawczy to profil o znanej litologii znajdujący się w pobliżu profilu roboczego. Może to być profil wczytany z oprogramowania GeoStar. Profil roboczy tworzony jest poprzez porównanie jego wykresów sondowania z litologią profilu porównawczego lub profilu klasyfikacji parametrycznej. Profil klasyfikacji parametrycznej z charakterystyk to profil, którego litologia została określona wyłącznie na podstawie wyników sondowania przy pomocy metod Robertsona, Schmertmanna lub podobnych. Profil taki może w szczególnych przypadkach służyć jako pomocniczy.

Poniżej pokazano sposób wyboru profili z menu Widok
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Rys. 4.1 Wybór rodzaju profili z Menu
Na rysunku obok wykresu domyślnie rysowany jest profil roboczy, jednak możliwe są także profile:

- Profil roboczy obok porównawczego

- Profil uzyskany z klasyfikacji z charakterystyk

4.1. Metody wydzielania warstw 
Warstwy profilu mogą być wydzielane manualnie bądź automatycznie. Aby wydzielić warstwy manualnie wybieramy z menu Profil roboczy → Wydziel warstwy gruntów manualnie. Pojawi się nadążająca za myszką pozioma linia, a miejscu kliknięcia powstanie granica warstw.
Zmiana wydzieleń istniejącego profilu roboczego możliwa jest po wybraniu z Menu Profil roboczy → Ręczna zmiana położenia warstw gruntów lub ikony:
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Po naciśnięciu ikony możliwe jest przesuwanie wskazanej myszą granicy warstw na wykresie.

Wybranie z submenu Podziel umożliwia dodanie nowej zakończającej lub podział istniejącej warstwy.  Pojawia się wtedy pozioma linia podziału na głębokości wskazanej myszką. 
Wybranie Usuń usuwa wskazaną warstwę umożliwiając jej przyłączenie do górnej lub dolnej.  
Metody automatyczne wczytują warstwy sklasyfikowane na podstawie charakterystyk (np. Robertsona) lub wprowadzone do programu GeoStar. 
4.1.1. Metoda 1 – manualne wydzielenie warstw litologicznych na podstawie przebiegu Qc i Rf
1. Włączamy wykresy Rf i Qc 

2. Wybieramy z menu Profil roboczy → Wydziel warstwy gruntów manualnie 
3. Na wykresie pojawi się przesuwająca się wraz z myszką linia pozioma. W miejscach znacznej zmiany Rf (przejścia jednej warstwy w drugą) klikamy lewym przyciskiem myszy. Po wydzieleniu wszystkich warstw klikamy przycisk Wprowadź zmiany (Apply changes). 

4.1.2. Metoda 2 - wydzielenie warstw litologicznych z klasyfikacji gruntów na podstawie charakterystyk (np. Robertsona)
Przed przystąpieniem do wydzielenia warstw te metoda należy przeprowadzić klasyfikacje gruntów (rozdział 3.2). Metoda ta przypisuje także cechy wydzielonym warstwom.
1. Wybieramy z menu Profil roboczy → Utwórz warstwy gruntu na podstawie klasyfikacji (klasyfikacji parametrycznej)   
4.1.3. Metoda 3 – wydzielenie warstw litologicznych na podstawie litologii wprowadzonej do bazy danych GeoStar
Litologie wprowadzoną do bazy danych GeoStar można zaimportować do aplikacji CPT-Star i wykorzystać do obliczeń parametrów gruntów. Odbywa się to poprzez wybór z menu Plik → Importuj warstwy z bazy danych GeoStar. Warstwy z GeoStar można wczytać jako Profil roboczy lub jako profil porównawczy. Po wyborze pojawi się okienko otworów istniejących w bazie danych GeoStar i należy wybrać otwór, z którego pragniemy zaimportować litologie. Jeśli wczytamy jako profil roboczy głębokości wyliczanych warstw będą zgodne z wprowadzonymi do profilu GeoStar.
4.1.4. Metoda 4 – wydzielenie warstw litologicznych na podstawie profilu porównawczego
W metodzie tej postępujemy podobnie jak w metodzie 1 obserwując przebiegi Qc i Rf z tym, że podpowiedzią jest wczytany z boku profil porównawczy.  
Poniżej pokazano wydzielanie warstw na profilu roboczym przy pomocy profilu porównaw​czego znajdującego się na lewo od profilu roboczego.
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Rys. 4.2 Profil porownawczy i profil roboczy na jednym rysunku
Dane do profilu porównawczego można uzyskać z kilku źrodeł.

1. Z danych wprowadzonego otworu do bazy danych GeoStar. 

2. Z innego profilu CPT wykonanego wcześniej

3. Poprzez zwykłe skopiowanie profilu porównawczego wykonanego w innym programie i wklejenie go do programu CPT.

W celu wczytania Profilu z bazy danych GeoStar wybieramy z Menu Profil porównawczy → Wczytaj z bazy GeoStar. Na okienku dialogowym wybieramy z listy właściwy profili i zaznaczamy, czy będzie to profil porównawczy. W przeciwnym wypadku zaimportowany profil będzie wyłącznie profilem roboczym. Można także wczytać profil porównawczy jako roboczy i nastanie zmodyfikować go.

Aby wczytać dane do profilu porównawczego z innego wykonanego programem CPT należy wczytać profil znany poprzez wybór Menu Edycja → Kopiuj profil roboczy. Następnie po wczytaniu danych profilu roboczego wybieramy Edycja → Wklej profil jako profil porównawczy.
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Rys. Wczytanie profilu porównawczego/roboczego z bazy danych GeoStar

Ważna opcją jest wybór czy profile znajdują się na tej samej rzędnej czy też na różnych. Jeśli na różnych to konieczne jest zaznaczenie Ustaw wg rzędnych zadanych.   W przypadku tym konieczne jest wprowadzenie rzędnej profilu porównawczego w bazie danych GeoStar jak i rzędnej gruntu w nagłówku sondowania CPT (Plik → Nagłówek
4.2. Manualne ustawianie cech warstw (klasyfikacja)
Nacisnięcie warstwy na słupku Profilu roboczego spowoduje ukazanie się okienka umozliwiajacego wprowadzenie jej cech: 

· Litologii i symbolu gruntu ze słownika wraz z unikalnym kodem klasyfikacji.

· rodzaju gruntu (piaszczysty, spoisty, organiczny)

Przy wprowadzaniu litologii i symbolu gruntu korzysta się ze słowników gotowych lub modyfikowanych przez użytkownika. Każda pozycja ze słownika posiada unikalny Kod klasyfikacji. Kod ten jest wybierany automatycznie po wyborze pozycji ze słownika i umożliwia przyporządkowanie warstwy do metody obliczeń
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Rys. Po naciśnięciu warsty na słupku pojawia się okienko słownika

Na wykresie widoczne są dwie linie – wartości srednich paramatrów warstw (o ile zostaną wcześniej policzone) oraz wykres wielopunktowy pomiarów z kanału sodnowania: W kazdej chwili klikajac warstwę mozna nadać i zmienić jej cechy. 

Klasyfikacja i przypisanie cech odbywa się zgodnie z wybranym bieżącym słownikiem klasyfikacji gruntów.
5. OBLICZANIE PARAMETRÓW WARSTW

Do obliczenia parametrów warstw oprogramowanie CPT-Star stosuje wbudowane w program metody stałe oraz metody definiowane przez użytkownika. Metody stałe opisano w rozdziale 8. Sposób wprowadzania własnych metod użytkownika opisano w części 2 tej instrukcji 

Na tym etapie można przejść do obliczenia parametrów gruntu. Po wyborze z menu Warstwy → Tabela wyników obliczeń warstw profilu pojawi się tabelka:
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Rys. 5.1.1. Tabelka parametrów warstw gruntu

W tabelce widać podział na warstwy rodzaju gruntu wraz z klasyfikacją (kolumny 2-3) oraz przedziały podziału na stany gruntu (kolumny 4-5). Dalsze kolumny określają obliczone parametry warstw stanów gruntu.

Wybierając ikonkę Wszystkie jak i Wybrana można wybrać parametr do obliczania zarówno całego sondowania jak i wybranej warstwy. Program zawiera możliwość obliczeń następujących parametrów.
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Rys. 5.1.2. Parametry możliwe do policzenia

Kolorem pomarańczowym i czerwonym oznaczono metody które w danym momencie nie mogą zostać zrealizowane ze względu na brak niektórych koniecznych danych. Np. na rysunku powyżej wybrano obliczanie ciśnienia prekonsolidacyjnego Pp co zostało oznaczone kolorem czerwonym a okienku Method problems zapisano, że brak jest danych w kanele OCR co oznacza, że wcześniej należy obliczyć OCR.

Jeśli liczone jest parametr dla wszystkich warstw to program wybiera automatycznie metody dla warstw spoistych lub piaszczystych lub organicznych. W przypadku obliczania parametrów wybranej warstwy może być użyta i wymuszona metoda np. dla warstw przejściowych. Użytkownik może także zdefiniować samodzielnie metody obliczeń. Opisano to w części 2 dokumentacji.
5.1. Manualne korygowanie wartości średnich parametrów warstw

Po wyliczeniu, wartości średnie parametrów warstw mogą być widoczne na rysunku sondowania. W tym celu należy wcisnąć ikonkę ustawiania wartości średnich warstw (wskazana na górnym pasku zadań)
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Rys. Edycja wartości średnich parametru na profilu

Na wykresach parametrów będą rysowane dwie linie, 

· jedna łamana z wartościami pomiarów w punktach sondowania, 

· druga wyliczonych wartości średnich

Aby możliwa była korekcja wartości średnich parametru warstw należy

1. Wcisnąć ikonkę ustawiania wartości średnich warstw (wskazana na górnym pasku zadań)

2. Wybrać myszką odcinek edytowanej średniej

3. Po ukazaniu się okienka Wartość parametru dla Warstwy – skorygować Wartość
6.  SŁOWNIKI LITOLOGICZNE KLASYFIKACJI GRUNTÓW
Przy klasyfikacji można używać następujacych słowników:

· Lokalny zgodny z ISO14688-2

· Lokalny zgodny z DIN 18196
· Lokalny zgodny z GeoStar

· Bezpośrednio dostępny z oprogramowania GeoStar

· Słownik lokalny zdefiniowany indywidulanie przez użytkownika

Wybór słownika odbywa się z Menu Format –> Ustawienia słowników. Oprogramowanie wykorzystuje słownik bieżący oraz słownik domyślny. 

Słownik bieżący to słownik, który wykorzystano wcześniej do klasyfikacji wczytanego profilu i dotyczy bieżącego profilu.
Słownik domyślny to słownik, który będzie domyślnie użyty do nowo wczytywanych i opracowywanych sondowań. 
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Rys.  6.1 Wybór słownika klasyfikacji gruntów

Należy zwrócić uwagę by do opracowywanego profilu używać zawsze tego samego słownika. Jego zmiana wymaga ręcznego przeklasyfikowania wszystkich warstw. 
W przypadku, gdy wczytywane sondowanie zostało sklasyfikowane na podstawie innego słownika niż domyślny, słownik wczytanego profilu zostanie wczytany i ustawiony jako bieżący. Np. jeśli sondowanie X zostało wykonane przy pomocy klasyfikacji DIN, a jako słownik domyślny i bieżący ustawiony jest słownik ISO, to na czas obrabiania wyników sondowania X jako słownik bieżący zostanie ustawiony słownik DIN. 
[image: image21.png]Zrodio. | 2 |

e kg B G g e O === =
i |2 &
Cvise || Sownidopck || D

Wby kol
+ 2 oue gary ) omens Symbok gt
2 2 chazy 8 Kamienis T ———

Ry odu o

s @ amerie o [l - o ek ey P
© E e © wy | ¢

ot guna
» B 2 sty s wy | »

e e—
» B Poset 20 wren o2 ek | ¢ B |
o 00 asekdny R
= o2 [k LI A = D Wi S
s st sk gy E R et sorckvion
51 537 Zwir pylasty. SiGr 2wy s
52 23 2wir ilasty (pospéka ilasta) der 2wy P
o Bl e pastopaszcrty soscr v
62 537 2w piaszczysto-pylasty sisaGr 2wy P
» E2 sk ity e g || | »
» 05 sckiosty e wrem g || w | r
81 537 Piasek zapylony sisa piaski P
@ = sk iony R
91 37 Pyt z zawartsdia zwiru orsi Pty P
92 517 Pytilasty ze zwirem ordsi Pty P
i s G pyesta s | aw s T
w2 o Gnatasa wa | am s (]
110 544 Pyt Si Pty s
120 515 Pytilasty dsi Pty s
130 s51 it a ity s Kolor warstwy
140 554 Tipylasty. sicl ity s
® B Zctacing O {E—

= wiiei

150 o Gty orgnicne o L e -
w Gty e | -
" = : g O Odswiez
Fowsy  Popuoii Nty Osn_ Weew Ui G Zowed i





Rys.  6.2 Słownik na podstwie ISO14688-2
7. WSPÓŁPRACA Z PROGRAMEM GEOSTAR

Oprogramowanie CPT-Star jest kompatybilne w zakresie wymiany danych z oprogramowaniem GeoStar. Możliwe są następujące opcje

1. Pobranie (import) z GeoStar wydzieleń litologicznych i policzenie ich parametrów geotechnicznych w oprogramowaniu CPT-Star

2. Zapis wyników sondowania jak i policzonych parametrów warstw CPT do bazy danych GeoStar (Tabela GS_CPT). Należy zważać by o ile to możliwe słownik litologiczny GeoStar był zgodny ze słownikiem CPT-Star. W obu programach istnieje możliwość doboru słownika.
7.1. Pobranie wydzieleń litologicznych z bazy danych GeoStar
Z bazy danych GeoStar można pobrać wprowadzone tam wydzielenia litologiczne, użyć je jako warstwy (Layers) i w oprogramowaniu CPT-Star. Następnie można policzyć ich parametry. Aby było to możliwe w tabeli litologii GeoStar powinny być wprowadzone następujące parametry:

· Rodzaj gruntu - RODZ. GRUNT. (P,S,O,-)
· Kolory - KOLOR NA RYSUNKU (o ile chcemy by kolory profilu CPT były zgodne z oprogramowaniem GeoStar) 

Wczytanie odbywa się po wybraniu z Menu opcji Importuj warstwy z bazy danych GeoStar (Import layers from Geostar database). Pojawi się okienko z wyborem otworu, którego litologia ma zostać zaimportowana. Po imporcie po lewej stronie rysunku CPT pojawi się słupek z warstwami.

Uwaga: Kolory na rysunku w bazie danych GeoStar definiujemy naciskając z menu Litologia → Koloruj warstwy 

7.2. Zapis wydzielonych warstw i ich parametrów do bazy danych GeoStar
Wyniki sondowania wraz z wydzielonymi i sklasyfikowanymi warstwami można przenieść do programu GeoStar 6i/7i. Obywa się to z poziomu menu głównego Plik → Eksportuj dane do bazy danych GeoStar (File → Export to GeoStar software) lub z poziomu Tabela wyników stanów gruntu (Table of soil states). 

Dane można dopisywać do bazy danych GeoStar do istniejących otworów w lub tworzyć nowe otwory wraz z litologią i wynikami obliczeń parametrów.
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· Nie kopiuj parametrów litologii i warstw powoduje, że w bazie GeoStar nie są zachowywane warstwy z wynikami obliczeń warstw

· Utwórz nową litologię GeoStar i kopiuj z parametrami warstw powoduje, że w GeoStar tworzone są nowe wydzielenia litologiczne i kopiowane wraz z parametrami policzonymi w CPT-Star

· Kopiuj parametry warstw do istniejącej litologii GeoStar - opcje tę wykorzystuje się, jeśli wcześniej zaimportowano warstwy litologiczne z GeoStar, w oprogramowaniu CPT policzono ich parametry, a następnie wyliczone parametry pragniemy przekazać do istniejących wydzieleń w bazie danych GeoStar.

Zaznaczenie Otwórz tabele bazy danych GeoStar po eksporcie (Open GeoStar database table after export) powoduje utworzenie uruchomienie bazy danych GeoStar i ustawienie jej pozycji na wprowadzonym otworze. Wprowadzanie odbywa się zawsze do aktualnie wybranego tematu GeoStar

 Do bazy zostaną przeniesione informacje o położeniu sondowania, wydzielone warstwy wraz z litologią i obliczonymi parametrami stanu gruntu. Aby parametry stanów gruntu były widoczne w bazie danych należy na zakładce litologia wybrać Pokaż rozszerzone stany.  

Dane można pokazać na uniwersalnej karcie otworu. W tym celu po uruchomieniu karty należy wczytać szablon CPT-Full.KU1.

7.3. Wprowadzanie wykresów i danych warstw na uniwersalnej karcie otworu
Wyniki obliczeń CPT zachowane w bazie danych GeoStar można pokazać na uniwersalnej karcie otworu programu GeoStar w postaci tabelarycznej lub wykresów. O formie decyduje zastosowany szablon karty otworu. 
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Rys.7.4.1 Szblon parametrów CPT na karcie otworu GeoStar (CTP-FULL.KU1)
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Rys.7.4.1 Szblon wykresów CPT na karcie otworu GeoStar (CPT_WYKRES.KU1)
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Rys 7.4.1 Karta otworu w programie GeoStar - dane programu CPT-Star (szablon CPT-Full.KU1)
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Rysunek wykonano programem "GeoStar" Kartę opracował: Kowalski


Rys 7.4.2 Karta otworu w programie GeoStar z wykresem z programu CPT-Star (szablon CPT-Wykres.KU1)

7.4. Wprowadzanie wykresów na przekroje

Na przekrój wykonany w programie GeoStar można nanieść wykresy sondowania CPT. Są możliwe dwie metody:

1. Kopiowanie rysunku wykresu z CPT

2. Bezpośrednie wprowadzanie w aplikacji Przekroje wybierając menu Wstaw ( Sondowanie CPT. (wersja GeoStar Profesional i Ultimate)
Kopiowanie rysunku wykresu z CPT

 W tym celu wykonujemy stosowny wykres w programie CPT-Star, w skali zgodnej ze skalą pionowej przekroju a następnie wybieramy z menu Edit → Copy Specjalny → Graph 1 to clipboard a następnie w otwartym przekroju wskazujemy miejsce wklejenia przekroju wybieramy prawym przyciskiem myszy Wklej ze schowka Windows.  
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Przekrój wykonany w programie GeoStar na podstawie sondowań CPT

Bezpośrednie wprowadzanie wykresów w aplikacji Przekroje
Wstawianie wykresów niektórych parametrów sondowań statycznych CPT jest możliwa w programie Przekroje pakietu GeoStar (wersje Professional i Ultimate). W tym celu należy wcześniej w programie CPT-Star zachować Dane sondowania CPT do bazy danych GeoStar (File ( Export to GeoStar software zaznaczając co najmniej opcje Save Cpt file data to GeoStar CPT table) 

Następnie w oprogramowaniu Przekroje należy wybrać z menu Wstaw ( Sondowanie CPT i określić parametr. Tę metodą na przekrój można wprowadzić wykresy tylko niektórych parametrów.  (Qc i RF docelowo także ID i IL)
7.5. Ustawianie kodów (szrafur) dla bazy danych GeoStar – opcja dotyczy jedynie klasyfikacji parametrycznej na podstawie charakterystyk
Baza danych GeoStar korzysta z innych kodów niż CPT-Star. Kody w programie CPT-Star dobierane są dla zadanej metody klasyfikacji gruntów zgodnie z numeracja autora. Aby w bazie danych GeoStar użyć kodów dla niej właściwych wykorzystywane jest ich przekodowanie. 

Dobór stosownego kodu GeoStar można przeprowadzić w programie CPT-Star. W tym celu wybieramy Format → Options a następnie zakładkę GeoStar. Pokazano to na poniższym rysunku.
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Ponieważ każda metoda interpretacji w CPT używa innego podziału na grunty – kody ustawia się do aktualnie użytej metody klasyfikacji (użyta metoda wyświetla się dla na dolnym pasku okna programu). Po zmianę kodów należy je zachować naciskając Save configuration as current. 

Kody programu GeoStar można przejrzeć wybierając z Menu GeoStar: Słowniki → Słownik litologiczny. Numery kodów znajdują się w pierwszej kolumnie słownika.
8. WYKAZ ZAIMPLEMENTOWANYCH METOD OBLICZEN PARAMETRÓW GRUNTÓW
8.1. Stopień zagęszczenia gruntów sypkich ID (Relative density) 

Metoda 1 – zgodna z Polska normą PN-B-04452   

ID=0.79 log qc -0.165  

Metoda 2 – zgodna z Boldi 1986. (Cone Penetration Testing, T.Lune, PK. Robertson, J.J.M Powel, strona 84). 
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 gdzie C0 C1 C2 zależą od przekonsolidowania gruntów

Grunty normalnie skonsolidowane: C0=157, C1=0.55, C2=2.41
Grunty normalne i przekonsolidowane piaski: C0=182, C1=0.55, C2=2.61
8.2. Stopień plastyczności gruntów spoistych IL 

Metoda 1 – zgodna z Polska normą PN-B-04452   

Po wybraniu metody zgodnej z Polską normą pojawi się okienko;
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Rys. 8.2.1 Obliczanie IL warstwy metodą zgodna z Polska normą

8.3. Efektywny kąt tarcia ' (Effective friction angle)

Metoda 1 (Robertson & Campanella, 1983a)
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Metoda 2 (Senneset 1988)

Źródło: Cone penetrating Testing, str. 69-70

 Obliczanie odbywa się z nomogramu wykorzystując wzór 




’ = f (Bq, Nm)
Obliczany wstępne współczynnik Nm. zależy od rodzaju gruntu i głębokości. 

Grunty niespoiste

Z > 5m


Nm = [image: image32.png]9t~ %o
OTpo+ Ip %




Z ≤ 5m 
Nm = [image: image33.png]qt~ 9vo
O1po+1p%+10(5—2)




Grunty spoiste

Z > 5m 



Nm = [image: image34.png]4t~ %vo
a+ oy




Z ≤ 5m



Nm = [image: image35.png]4t~ %vo
a+ Gy0+ 20 (5-2)




Metoda 5 - Fi based on qc (PN-B-04452)
Metoda bazująca na qc wg: PN-B-04452
Metoda 6 -  Fi based on qc (Eurokod 7)
Zgodna z Polska normą PN-EN 1997-2 wg. Eurokod 7
’ = 13.5 x lg(qc) + 23 

8.4. OCR

Metoda 1 (Powel 1988)



  qt - vo

OCR = k *  -------------------- 



    ’vo

8.5. Współczynnik rozporu bocznego Ko

Metoda 1 (Ko (Mayne 1991)
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8.6. Naprężenie prekonsolidacyjne ’p

a. Dla piasków ’p = OCR * ’vo

b. Dla spoistych ’p = 0.33 * qt * vo

8.7. Wrażliwość St (tylko spoiste)


St = 7.5 / Rf
8.8. Niedrenowana wytrzymałość na ścinanie Su (aktualnie oznaczana cu)
Metoda1 (Lune 1997)

Su = k * (qt -vo)  

gdzie: k zależnie od rodzaju gruntu przyjmuje różne wartości

Metoda2 – zgodna z Polska normą PN-B-04452  

Su = (qt -vo) /Nkt  

gdzie: k zależnie od rodzaju gruntu przyjmuje różne wartości 
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Metoda3 – zgodna z Polska normą PN-EN 1997-2 wg. Eurokod 7  

Su = (qt -vo) /Nkt  

8.9. Moduł Edometryczny ściśliwości wtórnej Eoed
Metoda 1 (Eurokod 7 wg. EN-1997-2)

M = qc  

Gdzie:  zgodnie z tablicą
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8.10. Moduł ściśliwości M
Metoda1 (Kulhavy, Mayne 1990) 





M = qn   




Gdzie: qn = qc - ’vo

 SHAPE 


 SHAPE 



8.11. Uwagi końcowe

Wyniki wyliczeń można wydrukować lub przekopiować do programu Excel.

DODATEK I -  STOŻEK MECHANICZNY (BEGEMANA)

1. INFORMACJE OGÓLNE

2. KOREKTA DANYCH

2.1 Korekta Qc
3. OBLICZENIA

1. INFORMACJE OGÓLNE

Algorytmy interpretacji sondowań ze stożkiem mechanicznym (Begemanna) opracowano jako moduł dodatkowy do Pakiet CPT-Star, dodając pewne metody oraz odrzucając metody interpretacyjne oraz metody wyliczające parametry (stany) gruntu. Dotyczy to metod korzystających z ciśnienia u2. Jednocześnie program umożliwia korygowanie danych wczytanych ze stożka mechanicznego tak by odpowiadały parametrom ze stożka elektrycznego. Firma Soft-Projekt długo zwlekała z obsługą pomiarów ze stożkiem Begemanna ze względu na napływające informacje o jakości wyników. Jednak znaczne zainteresowanie użytkowników takiej sondy sprawiły ze opracowaliśmy stosowny moduł, jednak opracowane wyniki muszą zostać zweryfikowane przez użytkownika wykonującego interpretację. 

Aby przejść w tryb pracy sondy ze stożkiem mechanicznym należy wybrać z menu 

Format → Options, a następnie na dialogu, który się pojawi w ramce Cone options zaznaczyć Mechanical (Begemann).
2. KOREKTA DANYCH

2.1 Korekta Qc
Dla sondy ze stożkiem elektrycznym parametr qc wczytywany jest na kanał 1 i stad brany jest do dalszych obliczeń. W przypadku sondy ze stożkiem mechanicznym dane qc wczytywane są równolegle na kanał 1 oraz 14. Po wczytaniu możliwe jest sprowadzenie wartości qc do wartości odpowiadających wartościom ze stożkiem mechanicznym. Odbywa się to wg zależności 
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wg. Kulchawy and Marne (1990)

Aby dokonać korekty qc należy wybrać z menu Tools → qc(m) → qc(e). Po wyborze kanał 14 pozostanie niezmieniony zachowując oryginalna wartość qc pochodzącą z sondy, natomiast wartości kanału 1 zostaną skorygowane wg zależności 1.

3. OBLICZENIA

W dalszej kolejności pracujemy podobnie jak w przypadku sondy ze stożkiem elektrycznym jednak w celu klasyfikacji gruntów należy używać wyłącznie metody

1. Adaptacja nomogramu Marra

2. Robertsona z 1986 (wyłącznie opcjonalnie)

W przypadku wyboru sondy mechanicznej zostaną pokazane jedynie te metody obliczania parametrów gruntów które nie wykorzystują ciśnienia u2.
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Rys. 3.0 Współczynniki przemnożenia kanałów wczytywanych z sondy





if qc < 10 then  = 4.5


 if (qc >= 10) and (qc < 20) then  = 5


 if qc >= 20 then   = 5.5








      if Rf >= 1.3 then   = 0.95;


      if (Rf >= 0.9) and (Rf < 1.3) then  =1.05;


      if (Rf >= 0.7) and (Rf < 0.9) then  = 1.1;


      if (Rf >= 0.4) and (Rf < 0.7) then  = 0.15;


      if Rf < 0.4 then  =1.2;
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